Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I use Ubuntu 12.04.1 64bit. I always used my update settings set to "never check" and then manually check for updates when I need to. But the last week or so I saw that Ubuntu started checking for updates automatically every day. I went to the settings but is was still set to "never check".

So I changed it to "every two days" to see if that will help. Now it check 2 to three times per day automatically.

Why is it ignoring my update settings and automatically checks so randomly every day ?

Edit: Did the following with the help of gertvdijk:

On request checked if I have unattended-upgrades installed and I have. Used suggested command sudo dpkg-reconfigure -plow unattended-upgrades to configure it to not do automatic updates. Proceeded to check file /etc/apt/apt.conf.d/10periodic for the following settings:

APT::Periodic::Update-Package-Lists "0";
APT::Periodic::Download-Upgradeable-Packages "0";
APT::Periodic::AutocleanInterval "0";
APT::Periodic::Unattended-Upgrade "0";

and all is at zero after the configuration above.

Will monitor and provide feedback if this resolved the problem.

edit 2:

None of the above worked. My system just informed me of updates that is available , so it still is automatically checking.

share|improve this question
1  
What exactly makes you believe it's checking for updates rather than just notifying you about it? If it already has fetched a new list of packages from the repository with updates ready (compared to your system state) it will keep informing you that updates are available, but it doesn't have to check again for that. –  gertvdijk Jan 12 '13 at 12:01
1  
No it's not that. I know because every time there is different updates and I do install them. Then later in the day there will be some more different updates again. This is how I know it is checking for updates. –  Mazal Jan 12 '13 at 13:09
    
There certainly is something else on your machine running an APT-update command (reading your other comment)! Did you install other package manager or desktop environments, e.g. KDE? They may come with their own update managers (just a GUI in front of the same APT). And do you have the package unattended-upgrades installed by coincidence? –  gertvdijk Jan 12 '13 at 13:12
1  
I don't have any other DE's and the only other package manager I have installed is Synaptec but that works of the same settings. I do have that package you mentioned. I checked and saw it is installed. –  Mazal Jan 12 '13 at 13:21

2 Answers 2

One reason can be (for example) if you are adding a PPA and run "sudo apt-get update" you will be manually checking the repositories for any updated indexes. Update manager will then use this information and let you know if there are any updates.

share|improve this answer
    
Nope this is not the reason. I didn't run the update command –  Mazal Jan 12 '13 at 13:09

Try reconfiguring unattended-upgrades:

Run sudo dpkg-reconfigure -plow unattended-upgrades in a terminal which allows you to easily reconfigure its behaviour. Answer the first question with 'No'.

To be really sure, check the file /etc/apt/apt.conf.d/10periodic for the Update-Package-Lists to be disabled:

APT::Periodic::Update-Package-Lists "0";
APT::Periodic::Download-Upgradeable-Packages "0";
APT::Periodic::AutocleanInterval "0";
APT::Periodic::Unattended-Upgrade "0";

I suggest you go to Ubuntu wiki: AutomaticSecurityUpdates for more details on the configuration for that package.

share|improve this answer
    
I'm gonna remove it (never installed it anyway, must have been something else that added it) and will give feedback in few days if that was the problem. Thank you –  Mazal Jan 12 '13 at 13:44
    
Oh boy no , removing it is not an option. When I mark that for removal then the system wants to remove a whole lot of other system packages as well. I instead went for your second suggestion. A very simple yes or no and I selected no. Will see what happens now for a few days. –  Mazal Jan 12 '13 at 13:47
    
@Mazal Yeah, it seems installed with every -desktop task nowadays. For me it's installed as well (surprised), but configured to do nothing at all. See my updated answer. –  gertvdijk Jan 12 '13 at 13:54
    
Ok I checked that file on my side and it is all at zeros , guess due to that config I did. I'm just very confused as to why it only started the last week or so. Been using this install for about 6 months without this happening. –  Mazal Jan 12 '13 at 14:53
    
gertvdijk , ok I made some edits in the question. Is it ok like that ? –  Mazal Jan 12 '13 at 16:04

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.