Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have an ASUS N56DP laptop and I have Kubutu 12.10 working on it with the default graphics drivers. The system hangs if I use any of the additional drivers suggested by jockey-kde. I am thinking about installing the AMD catalyst 12.10 to get better graphics performance. The graphics card on my system is RADEON HD 7730 M.

Has anyone tried this out and want to share their experience? Thanks,

share|improve this question
add comment

3 Answers

Imho you should try to install Catalyst Driver on Kubuntu. It will enable 3D graphics acceleration.

Regards, Over Killer

share|improve this answer
    
thanks, but do you know if the driver is stable for this hardware configuration and works for quantal. –  floatingpoint Jan 13 '13 at 22:59
add comment

I've only just installed Kubuntu 12.10 (trying it out). I had the same "hang" problem after installing the AMD Catalyst 12.10 drivers. I'm going to try and install the AMD Catalyst 12.11 beta driver when I get home. If you Google around, there are many people experiencing problems with AMD's Catalyst 12.10 driver on Linux.

I'll report back here after I've performed the AMD Catalyst 12.11 beta install.

share|improve this answer
    
I bit the bullet and installed the driver. The installation went without any troubles; however after I restarted my computer, and started AMD catalyst control center, it just complains saying that no driver is installed !! Luckily my graphics drivers are still working ( I have no idea, which drivers are running the show). –  floatingpoint Jan 14 '13 at 20:58
add comment

When you switch to the Catalyst driver you have to add "nomodeset" to your kernel boot flags to turn off Kernel Mode Setting. The catalyst driver doesn't work with KMS.

PS: I also have this N56DP. Suspend/Resume always crashes for me. Have you had any luck with it? Also, it always tries to suspend when you close the lid. I haven't found any way to disable that, the usual power manager settings have no effect.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.