Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This question already has an answer here:

I have been trying to install ubuntu (I tried 12.04LTS, 12.10, 12.10-secure-remix) using the wubi installer on Windows 8 and all the three times ran into the same problem showing some cannot find /ubuntu/winboot/wubildr when I tried to start ubuntu.

I tried to change the boot settings from UEFI to Legacy and then my laptop restarted and showed that "No operating System Found".

I then tried to install Ubuntu using a cd and after a lot of effort and using boot repair,etc. I landed into a new trouble. When I select UEFI on, the laptop loads Windows and windows too does not detect ubuntu. When I select Legacy mode, it starts ubuntu, shows me an option to start windows 8 but gives an error showing windows failed to load.

So in legacy mode, i am able to use only ubuntu and in UEFI mode, I am able to use only Win8. Please explain any process of starting windows in legacy mode (which I tried without any success) or starting ubuntu in UEFI mode.

share|improve this question
    
What is "12.10-secure-remix"? –  user25656 Jan 12 '13 at 11:32
    
It is said that 12.10-secure-remix is the UEFI mode enabled (as it is said so) version of Ubuntu. It is not officially supportes by Canonical –  Vinay Chandra Jan 12 '13 at 11:41
    
Ubuntu-Secure-Remix is just an Ubuntu disc with 3 pre-installed little helpful tools (especially Boot-Repair). See help.ubuntu.com/community/UbuntuSecureRemix –  LovinBuntu Jan 14 '13 at 4:29
add comment

marked as duplicate by Braiam, Eric Carvalho, Seth, djeikyb, Avinash Raj Dec 29 '13 at 3:44

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

3 Answers

up vote 1 down vote accepted

You have installed Ubuntu in Legacy mode, but you need it in UEFI mode as Windows is in UEFI mode.

To fix this:

  1. set up your BIOS in UEFI mode, and disable SecureBoot /FastBoot /QuickBoot
  2. boot on your Ubuntu-Secure disc (in UEFI mode if possible), choose Try Ubuntu, run Boot-Repair's Recommended Repair
  3. Reboot the PC. You should see the GRUB menu with access to both Ubuntu and Windows.
share|improve this answer
    
I got the grub menu but when it boots,ubuntu opens but windows boot fails and it is asking to insert the disk to re install –  Vinay Chandra Jan 17 '13 at 12:04
add comment

If Windows 8 came pre-installed on your computer, it almost certainly boots in EFI mode. The last I heard, WUBI did not work with EFI-mode boots. Thus, any attempt to use WUBI with an EFI-booting Windows system is doomed to failure. You should switch tracks and do a standard (non-WUBI) Linux installation.

share|improve this answer
add comment

Try to turn off "Secure Boot" in UEFI, then install Windows 8 first, then install Ubuntu, and agree to install GRUB. It should detect both Windows 8 and Ubuntu.

share|improve this answer
    
Windows 8 is pre installed on the computer. Can we do something if windows is already installed and ubuntu is not installed –  Vinay Chandra Jan 12 '13 at 12:04
    
Just install Ubuntu on Laptop. But make sure that you turned off Secure Boot. It should work. //EDIT: LiveCD wersion of course. If something will not work just post here. –  Over Killer Jan 13 '13 at 17:25
    
This installed ubuntu as legacy but not i UEFI mode. Where can i change the ubuntu boot up setting as UEFI? –  Vinay Chandra Jan 14 '13 at 8:10
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.