Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Recently i updated my 12.10 ubuntu, ever since i got this strange wifi internet problem. Net works fine on the initial boot, after couple of web requests from a browser or command line or any tool, internet stopped working. I have to disconnect & connect the wifi to get it work again.

It happens every few minutes. Its frustrating. It was working fine before the upgrade. I am sure this is not the machine problem, because my dual boot win 8 works fine.

I tried iwconfig, this is the output

lo        no wireless extensions.

wlan0     IEEE 802.11bgn  ESSID:"jumbotron"  
       Mode:Managed  Frequency:2.437 GHz  Access Point: 08:86:3B:8C:C0:74   
       Bit Rate=150 Mb/s   Tx-Power=16 dBm   
       Retry  long limit:7   RTS thr:off   Fragment thr:off
       Encryption key:off
       Power Management:off
       Link Quality=50/70  Signal level=-60 dBm  
       Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
       Tx excessive retries:1  Invalid misc:2   Missed beacon:0

anybody know whats goin on?

Update:

I connected my android phone in wlan and enabled USB tethering with ubuntu machine. It works great.

So the problem is defenitly with wireless configuration or drivers

These are some configs i got

lshw -C network

  *-network               
       description: Wireless interface
       product: AR9485 Wireless Network Adapter
       vendor: Atheros Communications Inc.
       physical id: 0
       bus info: pci@0000:02:00.0
       logical name: wlan0
       version: 01
       serial: 00:08:ca:e6:6b:59
       width: 64 bits
       clock: 33MHz
       capabilities: bus_master cap_list rom ethernet physical wireless
       configuration: broadcast=yes driver=ath9k driverversion=3.2.0-23-generic-pae firmware=N/A ip=192.168.2.11 latency=0 multicast=yes wireless=IEEE 802.11bgn
       resources: irq:17 memory:dea00000-dea7ffff memory:dea80000-dea8ffff

ifconfig

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:1727 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1727 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:137632 (137.6 KB)  TX bytes:137632 (137.6 KB)

wlan0     Link encap:Ethernet  HWaddr 00:08:ca:e6:6b:59  
          inet addr:192.168.2.11  Bcast:192.168.2.255  Mask:255.255.255.0
          inet6 addr: fe80::208:caff:fee6:6b59/64 Scope:Link
          UP BROADCAST MULTICAST  MTU:1400  Metric:1
          RX packets:12133 errors:0 dropped:0 overruns:0 frame:0
          TX packets:11872 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:9352562 (9.3 MB)  TX bytes:1851594 (1.8 MB)

nm-tool

NetworkManager Tool

State: connected (global)

- Device: wlan0  [jumbotron] -------------------------------------------------
  Type:              802.11 WiFi
  Driver:            ath9k
  State:             connected
  Default:           yes
  HW Address:        00:08:CA:E6:6B:59

  Capabilities:
    Speed:           150 Mb/s

  Wireless Properties
    WEP Encryption:  yes
    WPA Encryption:  yes
    WPA2 Encryption: yes

  Wireless Access Points (* = current AP)
    *jumbotron:    Infra, 08:86:3B:8C:C0:74, Freq 2437 MHz, Rate 54 Mb/s, Strength 57 WPA WPA2

  IPv4 Settings:
    Address:         192.168.2.11
    Prefix:          24 (255.255.255.0)
    Gateway:         192.168.2.1

    DNS:             192.168.2.1
share|improve this question
    
It seems likely to be a regression in the kernel drivers, you should try a different version and see what happens. –  LtWorf Apr 28 '13 at 9:44
    
I know that you can always hunt down a solution but often all the pain (and time) involved simply isn't worth it if it's fixed in the next release (when I am writing: Ubuntu 13.04). Simply burn a cd or put it on a pendrive and test if it's working. If so update and live happily :) –  Pitto May 2 '13 at 16:06
add comment

4 Answers

About a year before, I was having problems with that same Atheros AR9485 on my Ubuntu "Natty Narwhal". Back then, Ubuntu not even recognized that hardware as integrated to the computer. I purchased a cheap USB wireless network adapter that has worked excellent on Ubuntu; it has the form of a USB pendrive, and I connect it through an extension wire (I read that for health purposes is better to place it 15 cm. far to your body).

The name of the adapter is "Realtek RTL8187B WLAN Adapter". --it works pretty good in Ubuntu by just conecting it to USB port. If you buy an adapter, I recomend you to take your laptop to the store and ask to try the adapter right there before buying it.

Today I have upgraded to Ubuntu Precise Pangolin LTS and now the atheros works..., but with that same problems you mentioned. So I prefer to go back to my Realtek adapter. I did it by disconnecting the Atheros network and allowing the Realtek:

1----Connect the adapter on USB port

2----left click in the network icon (on the top right of your screen)

3----click on "disconnect" atheros

4----click on "connect" the Realtek adapter (or whatever wireless adapter you have)


There is another method, but I haven't try it:

1----Obtain the Windows driver for your Atheros network card. (You can download it in
the official website of your computer)

2----Locate the specific file that ends with ".inf "

3----Install "ndisgtk" --use your linux repositories--.

4----Open ndisgtk

5----Select "install new driver"

6----choose the location of your windows ".inf" file and click "install"

7----click o.k.

for more information on this method google: "ndisgtk"

share|improve this answer
    
thanks @ajsdkrt, i ll try... –  RameshVel Apr 4 '13 at 5:31
    
Does the windows driver method work? I have been battling with this problem a while now, I have a USB adapter but I don't like it, it is in the way.. –  Kempe Apr 13 '13 at 9:27
add comment

http://www.emmolution.org/?p=253

I had something like this a while ago. I looked into dmesg and blacklisted some power settings. the link looks promising to me.

share|improve this answer
add comment

you should try to update the network manager:

sudo apt-add-repository ppa:network-manager
sudo apt-get update && sudo apt-get upgrade
share|improve this answer
    
i ll try that and let you know –  RameshVel Jan 12 '13 at 5:19
    
its already upto date –  RameshVel Jan 12 '13 at 5:32
add comment

I did all this comands and still not work - so I try just on the wifi using the keyboard combination FN+F2 | PROBLEM SOLVED

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.