Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I recently changed my external hard drive so that it can be read/edited by all, not just myself. In doing so I think I made it so only the root user can mount it. When I tried to mount it today I got this message:

Error mounting: mount exited with exit code 1: helper failed with:
mount: only root can mount /dev/sdb1 on /media/sdb1

What steps do I need to take to mount it, whether it be in the terminal or not?

Thanks!!

share|improve this question
    
Can you tell how you made your HD mountable only by root? –  Gaurav Sharma Jan 12 '13 at 5:43
1  
Can you post the content of your /etc/fstab, please? It may be that you simply need to add the "user" or "users" option to the relevant line in that file. –  Scaine Jan 12 '13 at 13:16

1 Answer 1

To mount as root, open terminal by pressing Ctrl+Alt+T, and then typing in:

sudo mount /dev/sdaX

..replacing X by the drive letter of the number of the drive you are trying to mount. To find the drive number, go under the "disks" application, or by typing "gnome-disks" in a separate terminal.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.