Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am using a Toshiba Satellite notebook with Xubuntu 12.10 x86_64. Just now, I installed the fglrx package to be able to use the propriety drivers for my graphics card. However, once I rebooted after installing the package, Xubuntu fails to load.

The loading screen (Xubuntu logo; left-right moving bar) appears for a few seconds before the screen turns black and a log of a bunch of daemons starting appears. I press ALT + F4 to log in to a terminal, but when I try starting Xubuntu by running startx, I get this error at the end:

...
Loading extension GLX
(WW) fglrx: No matching Device section for instance (BusID PCI:0@0:1:1) found
SetVBEMode failed

Fatal server error:
no screens found
(EE)
Please consult The X.Org Foundation support
        at http://wiki.x.org
 for help.
Server terminated with error (1). Closing log file.
xinit: giving up
xinit: unable to connect to X server: Connection refused
xinit: server error

I am stumped and I don't know what to do to solve this issue, and still be able to use the proprietary drivers.

If it helps, I found this:

$ sudo aticonfig --list-adapters
* 0.00:01.0 AMD Radeon HD 7310 Graphics

Can anyone help me solve the issue? Thanks.

Edit: Here is my /var/log/Xorg.0.log: http://ompldr.org/vaDFnbw

Edit2: I can manage to start X without the driver by disabling it (sudo jockey-text -d kmod:fglrx) but I still want to solve the issue and be able to use the proprietary drivers.

share|improve this question
    
First...don't apt-get install fglrx. Use jockey/jockey-gtk. There are reports that it works when it is installed correctly: askubuntu.com/questions/173481/amd-e1-1200-slow –  hbdgaf Jan 12 '13 at 1:19
    
There have been a few with problems installing fglrx in 12.10, many have had to install linux headers first sudo apt-get install linux-headers-generic. Before installing fglrx. Your issue looks a little different but it can't harm –  Chris Carter Jan 13 '13 at 20:37
    
You could try the solution outlined here; askubuntu.com/a/207270/82517 –  DrA7 Feb 24 '13 at 23:12

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.