Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

In my Xubuntu 12.10 install, using the multimedia keys doesn't actually have any effect. Even though the OSD shows changes in volume, the actual volume doesn't change. The same thing applies to the mute button. I don't want a specific application's volume to be changed - I want the system-wide volume to be increased/decreased/muted.

I looked at threads such as this one, but they didn't help. Also, I'm seeing this issue on a system-wide basis, not just in certain situations, like when playing YouTube videos.

share|improve this question
add comment

1 Answer

up vote 2 down vote accepted
  1. Go to the Xubuntu Settings Manager (xfce4-settings-manager) and navigate to Keyboard -> Application Shortcuts

  2. Add the following shortcuts:

    • For the volume up key, use the command amixer set Master playback 5%+
    • For the volume down key, use the command amixer set Master playback 5%-
    • For the mute key, use the command amixer set Master toggle
  3. Open the PulseAudio control app (pavucontrol) and try pressing the volume up/down and multimedia keys. If they don't work, try logging out and back in again.

  4. Press the volume up key until the volume has increased to 100% in both the OSD and in pavucontrol. This will "align" the two volumes, so they appear the same to you. Make sure that decreasing the volume to 0% results in both the OSD and pavucontrol becoming 0% with the same number of presses of the volume down button. If it doesn't, go back to the Settings Manager and adjust the percentages for the volume up/down commands entered in step 2 until they are aligned correctly.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.