Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

After 4 hours of trying to configure this I'm getting mad.

I've the next setup:

eth0: is the on board lan adapter and this one connect directly to a switch. eth1: is the lan adapter (pci card) that connects directly to the main router and internet.

I'm trying to connect multiple machines to this computer running a dhcp-server (isc-dhcp-server) on it. And then configure the other machines to boot using lan.

This my current settings for interfaces:

# interfaces(5) file used by ifup(8) and ifdown(8)
auto lo eth1 eth0
iface lol inet loopback

iface eth1 inet static
address 192.168.0.200
netmask 255.255.255.0
gateway 192.168.0.1
network 192.168.0.0
dns-nameservers 192.168.0.1 8.8.8.8

iface eth0 inet static
address 10.0.0.100
netmask 255.255.255.0
gateway 10.0.0.1
network 10.0.0.0

Note: With this configuration nothing works at all. If i remove the configuration of eth0 i can connect to internet an my router without problems. Otherwise nothing works.

And this my configuration to the dhcp:

ddns-update-style none;

option domain-name-servers 8.8.4.4, 8.8.8.8;

default-lease-time 600;
max-lease-time 7200;

# If this DHCP server is the official DHCP server for the local
# network, the authoritative directive should be uncommented.
#authoritative;

log-facility local7;

subnet 10.0.0.0 netmask 255.255.255.0 {
  interface eth0;
  range 10.0.0.100 10.0.0.200;
  option routers 10.0.0.2;
  option subnet-mask 255.255.255.0;
  option broadcast-address 10.0.0.254;
  option domain-name-servers 10.0.0.1, 10.0.0.2;
  option ntp-servers 10.0.0.1;
  option netbios-name-servers 10.0.0.1;
  option netbios-node-type: 8;
}

Thanks in advance!

share|improve this question
    
I don't think you need a gateway on eth0 - a gateway is "if nothing else matches send the request to this IP" thing, so it should generally be the IP of your DSL modem, and be configured on the interface which is physically connected to the modem. Apart from that, it's not quite clear what you're trying to achieve and what the problems are. "nothing works at all" is such a wonderful description... –  Sergey Jan 11 '13 at 23:37
    
@Sergey eth0 is connected to the switch. You should take a look again because everything is explained. –  Sein Oxygen Jan 12 '13 at 0:03
    
I'd suggest to split this question into at least 3 separate questions and solve the problem in steps: 1. properly configure network adapters (see my previous comment) so you can access internet from this machine; 2. Configure NAT so other machines connected to the switch can access internet via this machine while configured manually; 3. Configure DHCP; 4. deal with network boot. You'll find that many questions are already answered on this site or elsewhere in details. –  Sergey Jan 12 '13 at 0:21

1 Answer 1

you can do it by adding following commands to terminal

route del default
route add default gw 192.168.0.1
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.