Sign up ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

I've bought new ASUS X55C laptop (LINK), with no OS preinstaled (only DOS). I've installed Win7, since I got in box cd with Win7 drivers, and everything works fine.

Now, I want to install Ubuntu 12.04 (dualboot), and I tried it (from CD, without installation). I noticed that my network isn't worknig (wifi, LAN), keyboard commands doesn't work fine, etc...

I googled for ubuntu drivers, but all I've founded is this LINK. My question is this:

Can anyone tell me is Ubuntu going to work fine (network, keyboard,...) when I install it, although it doesn't work on "Try Ubuntu" mode? I wouldn't like to install OS that wouldn't work.

Sorry for bad english, and thanks in advance.

Here is the output of commands you asked for.

ubuntu@ubuntu:~$ lspci -n

00:00.0 0600: 8086:0104 (rev 09)

00:02.0 0300: 8086:0116 (rev 09)

00:14.0 0c03: 8086:1e31 (rev 04)

00:16.0 0780: 8086:1e3a (rev 04)

00:1a.0 0c03: 8086:1e2d (rev 04)

00:1b.0 0403: 8086:1e20 (rev 04)

00:1c.0 0604: 8086:1e10 (rev c4)

00:1c.1 0604: 8086:1e12 (rev c4)

00:1c.3 0604: 8086:1e16 (rev c4)

00:1d.0 0c03: 8086:1e26 (rev 04)

00:1f.0 0601: 8086:1e59 (rev 04)

00:1f.2 0106: 8086:1e03 (rev 04)

00:1f.3 0c05: 8086:1e22 (rev 04)

02:00.0 0280: 1814:3290

02:00.1 0d11: 1814:3298

03:00.0 0200: 1969:1091 (rev 10)


ubuntu@ubuntu:~$ sudo lshw -C network

*-network UNCLAIMED

   description: Network controller

   product: Ralink corp.

   vendor: Ralink corp.

   physical id: 0

   bus info: pci@0000:02:00.0

   version: 00

   width: 32 bits

   clock: 33MHz

   capabilities: pm msi pciexpress bus_master cap_list

   configuration: latency=0

   resources: memory:f7d10000-f7d1ffff

*-network UNCLAIMED

   description: Ethernet controller

   product: AR8161 Gigabit Ethernet

   vendor: Atheros Communications Inc.

   physical id: 0

   bus info: pci@0000:03:00.0

   version: 10

   width: 64 bits

   clock: 33MHz

   capabilities: pm pciexpress msi msix bus_master cap_list

   configuration: latency=0

   resources: memory:f7c00000-f7c3ffff ioport:e000(size=128)

share|improve this question
Did you configure the wireless connection? Don't assume you have the atheros wireless adapter, make sure the adapter is enabled in BIOS and show us the output of "sudo lshw -C network" – fabricator4 Jan 11 '13 at 20:12
Can you run lspci -nn from the LiveCD and edit the output into your question? You might just need a driver or two. – Seth Apr 8 '13 at 21:42
It has been a wile since my first question. Since then I have been avoidng using Ubuntu, but now, my study is forcing me to make it work. So, thank you in advance for your help. – rtm86 Jul 17 '13 at 23:08

2 Answers 2

Quick answer (without deeper research): it is highly unlikely that a component that fails in the live system will work in the installed system without extra work. Thats one of the purposes for Ubuntu Live CDs.

share|improve this answer

I bought the same serious and tried ubtuntu 12. 04. Which is good choice to work. But sometimes WiFi will not functioning. It showed me like disabled.

So i just fold the laptop, it will be in the standby or sleep mode. Than I will reopen it. Than the Wi-Fi will connected automatically.

share|improve this answer
This does not provide an answer to the question. To critique or request clarification from an author, leave a comment below their post - you can always comment on your own posts, and once you have sufficient reputation you will be able to comment on any post. - From Review – Aibara Iduas Nov 19 at 7:10
I am new to this forum. I don't have enough reputations to comment here. – Akelya Nov 19 at 8:12

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.