Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This question is an exact duplicate of:

I've read abt the ton of complications/problems ppl are facing with UEFI when installing Ubuntu alongside Windows, but I haven't been able to find a solution to the one I encountered.

I have a Windows 8 OS and we installed Ubuntu 12.04 next to it. However, the dual boot menu did not pop up upon reboot. It loaded Windows directly. (Secure boot & rapid technologies are disabled).

After some research & forum reading, we verified that Ubuntu was indeed present in the EFI partition and we ran boot-repair. Eventually, the boot menu appeared, but it did so at every second reboot (from a shutdown not a restart). Then, it disappeared again and the laptop goes directly into Windows.

When the dual boot menu appeared, we went into Ubuntu and life was good so the installation -or some parts of it- worked... But how do i now get the dual boot menu to appear as it's supposed to?

Furthermore, I read that with Windows 8 the dual boot menu becomes graphical... But we just had the regular old list.

Any tips??

Thanks!

share|improve this question

marked as duplicate by Braiam, Kevin Bowen, guntbert, Eliah Kagan, Eric Carvalho Sep 6 '13 at 10:44

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

1  
What do you mean when you say with Windows 8 the dual boot menu becomes graphical? Are you waiting for the faces of Bill Gate and Richard Stallman or something like that? –  Lucio Jan 11 '13 at 19:35
    
LOL No... I read somewhere that it's a little bit like the Windows 8 metro screen with two options. But I care more abt getting the menu to load rather than what it looks like. It was just out of curiosity. Thx! –  user121558 Jan 11 '13 at 19:39
    
Ok, I'm just kidding.. Now seriously, if you turn on your computer, you see the GRUB? You must turn on, turn off and turn on again to enter to the GRUB? Also, here is an example of the GRUB.. –  Lucio Jan 11 '13 at 19:40
    
No grub... :-( It graced us with its presence a few times after having tried almost everything uefi-related & proposed under the sun and then not anymore. –  user121558 Jan 11 '13 at 19:43
    
I will recommend you to see this post of a Windows 8 user with your same problem. Read all and try with some method of there.. After, if you still have problems, you can edit your question adding more information like things that you did but that doesn't worked. –  Lucio Jan 11 '13 at 19:49

2 Answers 2

As I read it, GRUB isn't appearing at all when you boot; the computer is booting straight into Windows. If so, you probably need to use the Windows bcdedit program from a Command Prompt window started with Administrator privileges:

bcdedit /set {bootmgr} path \EFI\ubuntu\grubx64.efi

Be sure to type that command precisely. Note the difference between slashes (/) and backslashes (\), and note that the curly braces ({bootmgr}) don't denote a variable; type them as-is.

Note also that GRUB is not part of Windows, so its appearance doesn't change with Windows 8. Windows does come with its own boot loader, but AFAIK, on UEFI systems, it's really only useful for selecting between different Windows installations; it can't redirect the boot process to another OS. If you want a graphical boot manager, look into my rEFInd, which can redirect to the Windows boot loader (which will boot Windows directly) or to GRUB (which can boot Linux automatically or present its own menu, depending on its configuration). With 3.3.0 and later kernels, rEFInd can boot them directly, bypassing GRUB; but Ubuntu 12.04 ships with 3.2.0 kernels, so you'll need to upgrade your kernel if you want to use rEFInd without GRUB.

share|improve this answer
    
Hi! is there anyway to make sure if \EFI\ubuntu\grubx64.efi is available in my system? especially, to show the boot options I have using bcdedit tool? coz' I believe I've installed both win8 and ubuntu but the boot menu of grub does not show up –  Shawn Le Jul 30 '13 at 5:01
    
I tried your command already. But the booting still jumps directly to windows 8 :|. hix.. and I don't know how to revert the operation –  Shawn Le Jul 30 '13 at 5:21
    
If I understand correctly, the operation had no effect, so there's no point in "reverting" it. Instead, I recommend you first check your firmware settings for any options relating to Secure Boot, and disable that feature. If disabling Secure Boot doesn't help, check the computer manufacturer's Web site for a firmware (often called a "BIOS," although that's not technically correct) update. Install the latest one you can find. If that doesn't work, try running Boot Repair, which applies an ugly workaround for the ugly firmware bug. –  Rod Smith Jul 30 '13 at 16:19
  1. Disable FastBoot / QuickBoot in your BIOS (it may also be possible to disable it from within Windows)
  2. Reboot your pc
share|improve this answer
    
I tried this on a K45V asus laptop but it does not help to pop the grub boot menu up either –  Shawn Le Jul 30 '13 at 4:00

Not the answer you're looking for? Browse other questions tagged or ask your own question.