Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm running Kubuntu 12.10. I have a nVidia GT-430 video card with a large 27" 2560x1550 monitor hooked up with dual-link DVI and a smaller 21" 1920x1080 monitor hooked up with HDMI. Before I log on, the login manager appears to be using both monitors separately (the list of userids is spread across both monitors), but as soon as I log in, it makes them clones of each other. I have to go in and change the "Position" of the smaller monitor from "Clone of" to "Left of". It doesn't matter whether I click "Save as Default" or not, I still have to reset it every time.

I look in .kde/share/config/startupconfig and I see what looks like the right commands:

# krandrrc Display ApplyOnStartup false
krandrrc_display_applyonstartup=true
# krandrrc Display StartupCommands ''
krandrrc_display_startupcommands='xrandr --output DVI-I-1 --pos 1920x0 --mode 2560x1440 --refresh 59.9506
xrandr --output HDMI-0 --pos 0x0 --mode 1920x1080 --refresh 60
xrandr --output DVI-I-1 --primary'
# krandrrc [Screen0]
# krandrrc [Screen1]
# krandrrc [Screen2]
# krandrrc [Screen3]

Note the --pos 1920x0 for DVI-I-1, which is correct. Similarly, .kde/share/config/krandrrc also appears to have the correct offset of the big screen to put it to the right of the small screen:

[Display]
ApplyOnStartup=true
StartupCommands=xrandr --output DVI-I-1 --pos 1920x0 --mode 2560x1440 --refresh 59.9506\nxrandr --output HDMI-0 --pos 0x0 --mode 1920x1080 --refresh 60\nxrandr --output DVI-I-1 --primary

[Screen_0]
OutputsUnified=false
UnifiedRect=0,0,0,0
UnifiedRotation=1

[Screen_0_Output_DVI-I-1]
Active=true
Rect=1920,0,2560,1440
RefreshRate=59.9505500793457
Rotation=1

[Screen_0_Output_HDMI-0]
Active=true
Rect=0,0,1920,1080
RefreshRate=60
Rotation=1

[Screen_0_Output_HDMI-1]
Active=true
Rect=0,0,1920,1080
RefreshRate=60
Rotation=1

How can I get this working the way it's supposed to? I'd like to get this working because in a month or two I'm going to buy a second GT-430 and a second 27" monitor, and I'd like to have this all working.

share|improve this question
add comment

2 Answers 2

Not a perfect solution by any means, but I seem to have a work-around - I brought up the nvidia-settings program, and clicked on "X Server Display Configuration", made sure it was showing the layout I wanted, and clicked "Save to X Configuration File", and saved it to /etc/X11/xorg.conf.

Credit to http://www.muktware.com/articles/3081/how-set-dual-monitor-kde-nvidia-settings#.UPBmByZQAx4

share|improve this answer
add comment

This is my workaround.

nano ~/.kde4/Autostart/setupscreens.sh

fill with the following code

#!/bin/bash
foo=$(sed '3q;d' $HOME/.kde4/share/config/krandrrc)

${foo:16}

save (ctrl-o) and exit (ctrl-x)

now make it executable

chmod +x ~/.kde4/Autostart/setupscreens.sh

What it does is run the xrandr command generated by the system settings GUI when you setup your screen. I have no idea why for many this is not properly executed on login but for me this was a simple fix that works if I change my setup in the future using the system settings.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.