Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am using UCK-remaster to remaster a mini ubuntu 12.10 iso. Now I want to boot a remastered live cd that always shows / displays the grub2 menu. Now It only shows when i press a button. I dont want to press a button to show the menu, it has to boot directly into the grub2 menu!!!!.

I am changing /etc/default/grub.cfg like this:

    sudo uck-remaster-chroot-rootfs

Edit the /etc/default/grub file. Here is my CURRENT grub file (Already tried to # both #GRUB_HIDDEN_TIMEOUT=0 and GRUB_HIDDEN_TIMEOUT_QUIET=true without any luck. Also did update-grub):

    # If you change this file, run 'update-grub' afterwards to update
    # /boot/grub/grub.cfg.
    # For full documentation of the options in this file, see:
    #   info -f grub -n 'Simple configuration'

    GRUB_DEFAULT=0
    #GRUB_HIDDEN_TIMEOUT=0
    GRUB_HIDDEN_TIMEOUT_QUIET=true
    GRUB_TIMEOUT=-1
    GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
    GRUB_CMDLINE_LINUX=""
    GRUB_DISABLE_OS_PROBER=TRUE

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"

Thank you

share|improve this question
    
You have a Grub_timeout=-1. Try increasing this to 10 like the default setting. –  To Do Jan 11 '13 at 16:34
    
Changed it, did not work in the live CD. How do I reinstall / update grub2 in a chroot envriorment, using uck? –  user1602596 Jan 16 '13 at 11:43
    
After changing it you need to sudo update-grub for it to work. –  To Do Jan 16 '13 at 13:51
    
"After changing it you need to sudo update-grub for it to work". REMEMBER I am using uck-remaster to remaster a mini ubuntu remix CD. I dont need to sudo, iḿ already in chroot environment. I know update-grub is linked to /bin/true, so I use update-grub.old. But this doesn’t work either. –  user1602596 Jan 17 '13 at 14:31
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.