Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Using Sound Juicer I am able to rip CDs very conveniently. I would like to rip them in about 256 kbit/s variable bitrate. To accomplish this I have defined the settings for mp3 in gnome-audio-profiles-properties as follows:

audio/x-raw-int,rate=44100,channels=2 ! lame name=enc mode=0 vbr-quality=0 ! id3v2mux

where vbr-quality=0 should give me a variable bitrate averaging 245 kbit/s. The resulting files however always say they are in 128 kbit/s.

When I change vbr-quality from 6 to 0 all resulting files differ in exactly 1 Byte only when comparing them with cmp file1.mp3 file2.mp3. This means vbr-quality settings have no effect here.

share|improve this question

1 Answer 1

up vote 0 down vote accepted

The setting for Lame are incomplete. We will have to define VBR mode 4 as well to obtain the desired results:

audio/x-raw-int,rate=44100,channels=2 ! lame name=enc mode=0 quality=0 vbr=4 vbr-quality=0 ! xingmux ! id3v2mux
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.