Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I need to open a terminal I press CTRL+ALT+T to save time. Most of the time absolutely nothing happens, I try to press same combination again, and still nothing happens. After like 5-8 tries terminal window finally appears. Sometimes terminal opens on a first try.

This is a very annoying situation.

I also noted that open rate increases when I click on random spot on my desktop when all windows are hidden.

Also, when terminal finally is open, next CTRL+ALT+T combinations open new terminal window immediately.

There are no loadings when combination does not work, which means terminal will not appear even if I wait.

Ubuntu 12.10

Current computer: ASUS P5K-E/Wifi-AP MB, CPU Q6600 Quad Core @ 2.4ghz, GFX GTX560Ti, DDR2 RAM @ 800mhz 4gb

What am I doing wrong? Maybe there is some "focus" in shortkeys, global shortkeys, etc?

share|improve this question
    
@vasa1 I tried with different keyboards on different computers, same story. When I run terminal via Dash or launcher terminal window appears immediately. –  Maxim R Jan 11 '13 at 13:55
    
In other words, you have the same keyboard problem on totally different computers (with their own keyboards), but all running Ubuntu 12.10? By the way, do you have problems with any other shortcuts described here. –  user25656 Jan 11 '13 at 14:02
    
@vasa1 manufacturers of keyboards are different, but the problem is the same. Thanks for the link, I tried other shortcuts and everything works instantly once I try combinations. Problem always in opening terminal. –  Maxim R Jan 11 '13 at 14:10

2 Answers 2

this going to sound silly but you actually have to press CTRL + ALT first and hold them and then press T atleast a second holding both and then the third

share|improve this answer

It may actually be working the first time, and is just taking a long time to appear. Try first opening System Monitor from the dash, and watching what happens when you hit Ctrl-Alt-T.

You can watch for CPU/memory spikes or for the process name (gnome-terminal, bash) to show up in the list. If that happens right away, then you know it's not a keyboard problem.

You may also be able to use 'xev' to debug whether the keys are being sent correctly.

My guess is that there is something in your .bash startup scripts that is doing a network lookup or something else slow, which is delaying the terminal's appearance.

share|improve this answer
    
I used the 'xev' to debug whether the keys are being sent correctly. When terminal windows appears instantly: keys: 53 0 0 0 32 0 0 0 1 0 0 0 0 And when keys did not work: keys: 4294967188 0 0 0 0 0 0 0 0 0 0 0 0 Also, when keys did not work I see in debug output after like 10 seconds or even more same output as If terminal was open. Full debug log: pastebin.ca/2301579 –  Maxim R Jan 12 '13 at 15:14
    
based on that, it seems like the keypress is not getting through. Can you try setting up a different keyboard shortcut to open a terminal, without using alt, and see if that one works? –  ImaginaryRobots Jan 14 '13 at 17:56

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.