Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've been searching the askubuntu forum for the past 3 days trying to figure out what's going on with my system and I have tried a lot of things but to no avail. So, I will explain my situation and tell you what I have tried and I hope someone can help me :)

I have an: HP Workstation xw4100 Pentium(R) 4 3.00 GHz 1.5 GB RAM NVIDIA Quadro4 380 XGL graphics card

It came with Windows XP and I set it up (with WUBI) to dual boot with Ubuntu 12.04

After installation I had the problem that so many people had with it booting to a black screen (mine was actually booting to the terminal basic shell) that is fixed by adding nomodeset into the grub. When I do that, MY screen resolution becomes stuck in 1280x768 (as opposed to 1366x768 before adding nomodeset) (and also, when running XP the best resolution is 1280x720)

When I go to "additional drivers" it doesn't show any proprietary drivers, so I manually downloaded them using this command:

sudo apt-add-repository ppa:ubuntu-x-swat/x-updates
sudo apt-get update
sudo apt-get install nvidia-current

but after rebooting, that made the graphics even worse (now stuck as 800x600) SO I tried to configure the drivers with sudo nvidia-xconfig but that simply created an empty xorg.config file. I found one place where a guy gave information to manually input into the xorg.config file but that had no effect at all.

Lastly I tried to install previous versions of the NVIDIA drivers, but they wouldn't even fully install.

So now I have just re-installed Ubuntu 12.04 and I either need to find a better solution to the first problem (nomodeset) or get the nouveau driver to correctly configure to work with my nvidia graphics.

Thanks for your help ahead of time!

share|improve this question

I guess that is the wrong repository to use (if the FLOSS driver "nouveau" does not work), start by removing the packages you have installed and repository you have added to avoid conflicts.

Please try with the steps explained in this blog post at the last section "Setting up Nvidia Optimus"

this will install the latest Nvidia proprietary drivers :

sudo apt-add-repository ppa:xorg-edgers/ppa
sudo apt-get update
sudo apt-get install nvidia-current nvidia-settings

If you are sure you have optimus features or a second integrated graphics cards like Intel you can proceed with Bumblebe installation as following :

sudo add-apt-repository ppa:bumblebee/stable
sudo apt-get update
sudo apt-get install bumblebee bumblebee-nvidia
share|improve this answer

Looks like this person had the same problem and was able to rectify it by editing the xorg.config file. You can run the commands yourself or just copy and paste the config file the author posted in the comments.

share|improve this answer
Thank you for answering, but that is the link that I linked to in my original question. When I ran the code 'nvidia-xconfig' it only created a blank 'xorg.config' file. and when I pasted the information from that page into my own file, it didn't make a difference. Do I have to do something else after pasting the information into the 'xorg.config' file? – Thunder Jan 11 '13 at 13:47
Ah sorry about that! I clearly see it there now, must have missed it on the first read, my bad! Just a reboot is all you have to do after it. Hmm did you copy the code from the comments or from the terminal output? – Merri Jan 11 '13 at 13:59
Yes I did, but it didn't make a difference. Right now I am running on the reinstall and I haven't set the 'nomodeset' yet, so all the graphics work fine. But when I reboot I have to hit the escape key to keep from booting into the BIOS. It's kind of annoying, but it's less annoying than having the resolution all messed up. Is there some other fix besides setting nomodeset? – Thunder Jan 11 '13 at 14:45
I'm all out of ideas sorry! I thought maybe you could have nomodeset enabled but specify a screen resolution of 1366x768 in /etc/grub by adding vga=XXX (Where XXX is the Vesa Bios mode number). But it seems that there isn't a Vesa Bios mode number for 1366x768 unfortunately. – Merri Jan 11 '13 at 15:42
Is there a VESA BIOS mode number for a resolution that is 16:9 (like when I run XP I have it set to 1280x720). I didn't see one on that wikipedia link you put up but I don't know if that is an exhaustive list. – Thunder Jan 11 '13 at 18:06

I had the same problem with my computer and I solved it installing the bumblebee drivers for NVIDIA graphic card. I'm not sure it will work in your case because I have a laptop, not a desktop computer, and maybe this solution is good only for laptop graphic cards. You can still give it a chance.

Try getting into ubuntu with nomodeset and then type into terminal:

sudo add-apt-repository ppa:bumblebee/stable
sudo add-apt-repository ppa:ubuntu-x-swat/x-updates
sudo apt-get update
sudo apt-get install bumblebee bumblebee-nvidia linux-headers-generic

Now reboot and check if it works.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.