Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm having problems with real slow file transfers across a network.

I have 2 pc's running windows 7 and an ubuntu server attached to a Netgear gigabit switch (GS605) which is linked to a BT home hub router.

When the ubuntu server is plugged into the switch I get real slow speeds for file transfers from windows pcs to the ubuntu server of about 150KB/sec.

If I unplug the servers cable from the switch and plug it into the BT home hub and do a file transfer it will work at a rate of about 10MB/sec.

From windows to windows pc it seems a lot faster through the switch, over 25MB/sec.

Has anyone got any idea why the Ubuntu server is so slow when attached to the switch and what I can look at to fix it.

All the lights show as yellow on the switch to signify 1Gbps connection and the server has a new cat 6, 3m long cable.

share|improve this question
    
...also when the server is plugged into the router the network activity light only flashes about once every 3 seconds when idle. When it's plugged into the switch it constantly flashes. –  Scott Jan 12 '13 at 15:09
add comment

1 Answer

This sounds perhaps like a bad port. I searched and found differing models of your BT Hub. I note that some have only one GigE port and the rest labeled just with network symbols. They may be 10 or 100Mb.

Have you tried a different port on the switch? You likely have. Power cycle the switch if you haven't - they can get stuck. Try a different cable. When you say 25MB windows to windows this sounds like peer to peer. If that is Samba, that is about right.

You can do some diagnostics with your cables plugged in various ways:

Open a terminal in windows (bit rusty here) but I think START | RUN | cmd will do it. and the command ipconfig

Open a terminal in Ubuntu and type

ifconfig

You should get output like this:

eth0  Link encap:Ethernet  HWaddr bc:5f:f4:7b:2b:15  
      inet addr:192.168.1.xxx  Bcast:192.168.1.255  Mask:255.255.255.0
      inet6 addr: fe80::be5f:f4ff:fe7b:2b15/64 Scope:Link
      UP BROADCAST RUNNING MULTICAST  MTU:6144  Metric:1
      RX packets:1154500 errors:0 dropped:0 overruns:0 frame:0
      TX packets:2387670 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 txqueuelen:1000 
      RX bytes:301919244 (301.9 MB)  TX bytes:2653133922 (2.6 GB)
      Interrupt:56 Base address:0xe000

Bad connections might show as errors or dropped packets

Safe tool to install if not already is 'ethtool'. if you have an internet connection:

sudo apt-get install ethtool

Run as superuser: sudo ethtool eth0
This what my 12.04.1 server reports:

Settings for eth0:
Supported ports: [ TP MII ]
Supported link modes:   10baseT/Half 10baseT/Full 
                        100baseT/Half 100baseT/Full 
                        1000baseT/Half 1000baseT/Full 
Supported pause frame use: No
Supports auto-negotiation: Yes
Advertised link modes:  10baseT/Half 10baseT/Full 
                        100baseT/Half 100baseT/Full 
                        1000baseT/Half 1000baseT/Full 
Advertised pause frame use: Symmetric Receive-only
Advertised auto-negotiation: Yes
Link partner advertised link modes:  10baseT/Half 10baseT/Full 
                                     100baseT/Half 100baseT/Full 
                                     1000baseT/Half 1000baseT/Full 
Link partner advertised pause frame use: Symmetric Receive-only
Link partner advertised auto-negotiation: Yes
Speed: 1000Mb/s
Duplex: Full
Port: MII
PHYAD: 0
Transceiver: internal
Auto-negotiation: on
Supports Wake-on: pumbg
Wake-on: d
Current message level: 0x00000033 (51)
               drv probe ifdown ifup
Link detected: yes

Hope that helps. cheers

share|improve this answer
    
Thanks for the reply. I have tried different ports in the switch and rebooting it many times. I didn't realise the bt hub had a gigabit port, just assumed they were all 100mb. I have tried plugging the server into that and get a speed of about 600KB/second from windows pc to the server. The file transfers are just using copy and paste which I assume is samba. I notice using ethtool that 'Link partner advertised auto-negotiation : No' but both the windows pc's have auto negotiation turned on, not sure if this would cause the problem. –  Scott Jan 14 '13 at 11:28
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.