Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am using Ubuntu 12.10.

I want to install network printer Toshiba e-Studio 455, but in Driver database there are only entries for 450, 450s, 451c, 452 and 453.
When I used driver for 450 and tried to print test page, printer printed page with following context:


How can I install this printer to work properly or from where can I download a correct driver?

share|improve this question
Here is the link to download the drivers for your printer… – VRU Jan 11 '13 at 10:31
OK, I followed link. How to install these drivers? I there some linux binary... – Michał Herman Jan 11 '13 at 10:40
Herman I would suggest you to first visit this link and check compatibility with current linux versions – VRU Jan 11 '13 at 11:05
Herman in looking for a solution to the issue you are facing. I got to know that this a bug which is already reported and people are trying to diagnose it.Here is the link – VRU Jan 11 '13 at 11:42
@VRU Thank you for info. I am maybe stupid, but status Fix Released doesn't mean, that they release the fix and bug should not occur now? – Michał Herman Jan 11 '13 at 12:10
up vote 5 down vote accepted

A workaround is:

lpadmin -p TOSHIBA-ColorMFP  -o pdftops-renderer-default=pdftops

if, your printer is indeed called TOSHIBA-ColorMFP. Check the name of your printers with:

lpstat -a
share|improve this answer
I have no idea what it is doing, but it's working – Michał Herman Feb 5 '13 at 12:22
It is forcing a render to postscript through GNU Postscript and sends that to the printer. This will fix many things, since GNU postscript is much more forgiving when parsing PDF than some printers are. If I understand things correctly... @MichałHerman – Prof. Falken Feb 5 '13 at 12:24
Via the GUI you can also go to Printers (search for it in Unity) -> right click the printer -> Printer Properties -> Job Options -> Other Options (Advanced) (at the very bottom of the page) -> Add a new option -> "pdftops-renderer", then set its value to pdftops and apply. – pix Dec 4 '13 at 5:25
@pix, cool, thanks. – Prof. Falken Dec 4 '13 at 7:59

Another workround is to use the "Generic PCL" driver as the eStudio printers don't like being sent font data by postscript - the PCL6XL drivers will even do colour.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.