Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have been trying to install VirtualBox on Ubuntu 10.04. Here are the commands I entered:

sudo add-apt-repository ppa:debfx/virtualbox
sudo apt-get update
sudo apt-get install virtualbox

And here is the error I am getting in the Terminal:

The following packages have unmet dependencies:
  virtualbox: Depends: libvncserver0 but it is not installable
              Recommends: virtualbox-dkms (= 4.1.18-dfsg-1~lucid1~ppa1) but it is not going to be installed or
                          virtualbox-source (= 4.1.18-dfsg-1~lucid1~ppa1) but it is not going to be installed
              Recommends: virtualbox-qt (= 4.1.18-dfsg-1~lucid1~ppa1) but it is not going to be installed
              Recommends: libqt4-opengl (>= 4:4.5.3) but it is not going to be installed
              Recommends: libqtgui4 (>= 4:4.5.3) but it is not going to be installed
E: Broken packages

How can I fix this and get VirtualBox installed?

share|improve this question
1  
Any sensible reason why you chose to install Virtual Box from a ppa and not from the official repositories maintained by Oracle or via the Software Center? –  Takkat Jan 11 '13 at 9:15
    
@Takkat Is there actually an upstream repository, or just package files that must be manually downloaded and installed (and again whenever there is an updated version)? –  Eliah Kagan Jan 11 '13 at 9:20
2  
@EliahKagan: there are repositories for all versions from 1.6 to 4.2. maintained by Oracle: virtualbox.org/wiki/Linux_Downloads –  Takkat Jan 11 '13 at 9:22
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.