Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I cant use the microphone in my ubuntu 12.10. I don't know at all what it the reason. My sound settings input tab displays some device, but I am not sure if that is my microphone. I use the skype test call to test if the mic is working but I never hear my voice. Why I can't use my microphone? what is missing?

enter image description here

Update I tried also to use


This is how my settings there look like: enter image description here enter image description here

The second image looks like the mic is taking input, but it is not. That bar is there just shaking and is always the same lenght. I don't know what it could be. I just noticed that in this link it says that in msi laptops the mic does'nt work. Is there any way to fix it?

Here is my part of my hardware configuration:

Processor   2x AMD Athlon(tm) X2 Dual-Core QL-60
Memory  3791MB (913MB used)
Operating System    Ubuntu 12.10
User Name   username (username)
Date/Time   Sat 12 Jan 2013 00:35:23 GMT
Resolution  1366x768 pixels
OpenGL Renderer Unknown
X11 Vendor  The X.Org Foundation
Audio Adapter   HDA-Intel - HDA NVidia
Input Devices
Lid Switch  
Sleep Button    
Power Button    
Power Button    
AT Translated Set 2 keyboard    
ENE eHome Infrared Remote Receiver  
MCE IR Keyboard/Mouse (ene_ir)  
Video Bus   
Video Bus   
SynPS/2 Synaptics TouchPad  
HDA NVidia Line 
HDA NVidia Mic  
HDA NVidia Headphone    
HDA NVidia Line Out 
No printers found   
SCSI Disks
ATA WDC WD3200BEVT-2    
TSSTcorp CDDVDW TS-L633A    
Operating System
Kernel  Linux 3.5.0-21-generic (x86_64)
Compiled    #32-Ubuntu SMP Tue Dec 11 18:51:59 UTC 2012
C Library   Unknown
Default C Compiler  GNU C Compiler version 4.7.2 (Ubuntu/Linaro 4.7.2-2ubuntu1)
Distribution    Ubuntu 12.10

Name    MS-1671
Vendor  MSI
share|improve this question
Does the input level shown on that window react to mic input? – Jorge Suárez de Lis Jan 11 '13 at 1:13
Are you using Acer Aspire One 722? If so please go to and indicate you are affected by this bug. – user68186 Jan 11 '13 at 1:16
We need more hardware information to help you, can you look at this question and then edit your question adding the information. – Seth Jan 11 '13 at 1:20
@iSeth I am using an MSI laptop, sorry didn't answer before I didn't see the comment. – sfrj Jan 12 '13 at 0:41

Try to install Pulseaudio Volume Control (pavucontrol) Install banshee and check if your input port and profile selections for your sound card are correct. Such settings appears to be missing in the regular Sound Settings in Ubuntu.

General troubleshooting from here:

  1. Open pavucontrol.

  2. Click the Configuration tab.

  3. Locate the correct sound card (just one in your case, probably).

  4. Select the appropriate profile. For regular analogue sound, you should select something like Analogue Stereo Duplex. Options depend on the capabilities of your sound card.

    Screenshot (KDE, but looks similar in Unity):

    enter image description here

  5. Click the Input Devices tab.

  6. Locate the correct sound card again.

  7. Check the setting of the Port selection for it. My laptop offers me three options: Internal mic, Microphone (jack) and Line In.

  8. Check if it's unmuted.

    enter image description here

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.