Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.
$ head -1 /etc/issue && emacs --version | head -1
Ubuntu 12.04.1 LTS \n \l
GNU Emacs 23.3.1

From time to time I get undefined messages in the echo area (that do not show up in buffer *Messages*) about XF86WakeUp. In fact, I C-h led to see that there are 22 such <XF86WakeUp> keys in a row.

Reading How do I prevent the Sleep button from locking the screen

I figured out that the blue Fn-key left to Ctrl does this.

On the other hand, that very same key is needed to enable the Soundoff meaning of Esc, and similar for F1-F12. Just to make this clear: Emacs gets Esc directly. Thus, Esc does not mean Soundoff within Emacs. But Fn-Esc does.

So what is the clean way to fix this without affecting the other Fn keycombinations within Emacs?

share|improve this question
add comment

1 Answer

up vote 0 down vote accepted

This problem is solved most probably due to a recent update of 12.04.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.