Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I open the applications menu in Gnome Shell it lists everything I have installed including command line tools like bash and aptitude. Most of the GUI applications (Chrome, Libre Office etc.) have two icons each, and one is low resolution.

How do I remove or hide the icons which should not be there?

I have tried sudo update-menus and it does not work.

I am running:

  • Ubuntu 12.04
  • Gnome Shell 3.4.1
share|improve this question
1  
Typically Gnome and other Desktop Environments take their menu entries from /usr/share/applications, inside you'll find .desktop files, maybe delete them from there?. –  Uri Herrera Jan 10 '13 at 23:45
1  
@UriHerrera I checked and there are no duplicates or command line tools listed in /usr/share/applications. Is there any other directories where .desktop files are located? –  Kara Jan 10 '13 at 23:49

1 Answer 1

up vote 2 down vote accepted

I used alacarte. It should be installed with gnome3, but you can find it in the Ubuntu repositories if not. You can start it via terminal or the gnome3 menu.

Link to the Ubuntu Software Center: https://apps.ubuntu.com/cat/applications/alacarte/

In this program you can disable single programs or "folders". To deactivate the low resolution icons, just deactivate the "Debian" folder. This worked for me. I'm not sure whether I needed to start it via sudo, better try without first.

share|improve this answer
1  
This fixed my problem! For some reason I was unable to uncheck the Debian folder, I would uncheck it and then it would become checked again a second later. I navigated to each of the folders under the Debian folder and disabled the individual applications. –  Kara Jan 11 '13 at 1:45

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.