Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Can't launch Gnome Tweak Tool when the User Themes extensions is enabled.

When I tried from terminal, the output was:

petr@sova:~$ gnome-tweak-tool 

(gnome-tweak-tool:6475): GLib-GIO-ERROR **: Settings schema 'org.gnome.shell.extensions.user-theme' is not installed

Trace/breakpoint trap (core dumped)

Gnome Tweak Tool works correctly without User Themes.

Ubuntu 12.04, gnome-shell 3.4.1

Relevant (closed) question: Gnome-tweak-tool doesn't start

share|improve this question

2 Answers 2

up vote 5 down vote accepted

Similar question here

Howto:

Add the official Gnome Shell Extensions ppa:

sudo add-apt-repository ppa:webupd8team/gnome3
sudo apt-get update

Install dependencies:

sudo apt-get install gnome-shell-extensions
sudo apt-get install gnome-shell-extensions-common

Afterwards, enabling on the link provided works fine.

share|improve this answer
    
That just removes the extension. Don't want that. But the linked forum post solved my issue. Thanks! –  mreq Jan 10 '13 at 18:23
    
can you elaborate on the "FIX" I will include it in the answer –  Ringtail Jan 10 '13 at 18:27
    
Did that for you, thanks. –  mreq Jan 10 '13 at 18:35
    
@PetrMarek nice –  Ringtail Jan 10 '13 at 18:40

install the gnome shell extension user theme even though it gives error then run the following command

sudo cp $HOME/.local/share/gnome-shell/extensions/[email protected]/schemas/org.gnome.shell.extensions.user-theme.gschema.xml /usr/share/glib-2.0/schemas && sudo glib-compile-schemas /usr/share/glib-2.0/schemas

after that reload shell att+f2 then running r

here is the link where i got the solution http://www.fandigital.com/2012/09/fix-user-themes-gnome-shell-extension.html

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.