Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Possible Duplicate:
Boot screen in low graphics/text mode

The situation before this all happened is pretty standard. I have a HP Pavillion dv5 laptop with an ATI Mobility Radeon 4200 series. It always worked fine with Ubuntu for as long as I can remember. However, at one point, something happened and truly made a majestic mess of things. It might've been extra repos I enabled with Ubuntu Tweak - I do not know. But something made it so that my system would not boot any longer.

And when I say "won't boot", this is what I mean: - Durning a normal bootup, any entries (except Windows) selected with GRUB (or BURG, not even sure which one I'm using anymore) will spawn the Ubuntu loading screen - then try to start X (or GDM) 5 times. The screen goes to dark, black and back to the Ubuntu loading screen. Then it just stays there until I spawn another TTY.

I have no idea what is happening or why. There are no errors in my logs, and I'm truly at a loss here.

I've linked three files: Xorg.0.log, the output of dmesg and the GDM log:

Let me know if any of you more knowledgeable folks can restore some sanity in my life. Any help is greatly apreciated.

share|improve this question

marked as duplicate by Nitin Venkatesh, James Feb 24 '12 at 19:21

This question was marked as an exact duplicate of an existing question.

I have the same problem on my ATI Technologies Inc RV730XT [Radeon HD 4670] My solution now is just to use 2.6.35-24 and things work fine. I have not tried the purge yet.... will come back and update if that works. – hansioux Feb 20 '11 at 7:03
i tried reinstalling fglrx and get the same thing with kernel 2.6.35-25, while things works fine with 2.6.35-24. I get a segmentation fault when i do startx with 25. – hansioux Feb 25 '11 at 15:30
@pluc Please put a link to the gdm log here as a comment. Also let us know if you have been able to solve the problem or not, if you have, then please do answer your question and accept the answer :) – Nitin Venkatesh Feb 24 '12 at 0:35
Also FGLRX (Catalyst 11.6) is it compatible with kernel 2.6.39 provides insight to the asked question. – Nitin Venkatesh Feb 24 '12 at 0:44

Try to reinstal fglrx with

sudo apt-get purge xorg-driver-fglrx
sudo apt-get install xorg-driver-fglrx
share|improve this answer
@izx This is an answer, not a comment. It provides explicit instructions for solving the problem. I doubt they would work, but it's still an answer (and it wouldn't be any better as a comment). – Eliah Kagan Aug 15 '12 at 21:23
@EliahKagan: I only partially agree--"have you tried this?"-type short "answers" are IMO better put as comments. (And yes, the auto-comment inserted by review-beta isn't well-phrased). – izx Aug 16 '12 at 3:35

Not the answer you're looking for? Browse other questions tagged or ask your own question.