Sign up ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

I have recently started to configure my network using /etc/network/interfaces for a static IP address. For this I have added the following lines into the file:

auto lo
iface lo inet loopback

auto eth0
iface eth0 inet static

I have also changed managed=true in /etc/NetworkManager/NetworkManager.conf.

Everything works fine so far.

Today I realized that I have two identical default gateways (via a bash default gateway failover bash script that wouldn't work because of that reason).

Route shows the following:

Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
default         UG    0      0        0 eth0
default         UG    100    0        0 eth0
link-local      *          U     1000   0        0 eth0     *        U     0      0        0 eth0

The default gateway shows up twice, once with metric 0 and once with 100. Is this the way it is supposed to be?

There are no files in /etc/NetworkManager/system-connections so I have no idea where that gateway is coming from. I don't have any scripts running that would add the gateway.

How do I remove one of them so it's gone permanently?

share|improve this question

1 Answer 1

I could solve this problem by changing managed=false in /etc/NetworkManager/NetworkManager.conf

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.