Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

when installing scangear (using scangearmp-mp230series2.0-1-deb) for canon pixma mp230 it stops with

 Error: Dependency is not satisfiable: scangearmp-common (>= 2.00),   

and scanimage -L responds

No scanners were identified. If you were expecting something different,
check that the scanner is plugged in, turned on and detected by the
sane-find-scanner tool (if appropriate). Please read the documentation
which came with this software (README, FAQ, manpages).
share|improve this question
could you provide the packagename you are trying to install? – Gerhard Burger Jan 10 '13 at 12:39
scangearmp-mp230series2.0-1-deb – Marin Panovic Jan 10 '13 at 13:02
see the answers from… – Gerhard Burger Jan 10 '13 at 13:10
tried that didnt work gives mention error – Marin Panovic Jan 10 '13 at 14:22
I mean the other suggestion, trying to select the 250 in the ubuntu add printer dialogs – Gerhard Burger Jan 10 '13 at 14:32

Try to download the official tar.gz from (I had to choose the MP237 instead of the MP230, but that works too) , uncompress it, enter into the recent created directory, and then execute the following command:

sudo ./

It will install (in order) two packages that are inside the subdirectory 'packages', in first place the "common" package, and in second place the "mp230series" package.

share|improve this answer
An error occurred. A necessary package could not be found in the proper location when sudo ./ – Marin Panovic Jan 12 '13 at 9:07

The best thing you can do is download the printer driver and scanner driver from the Canon Asia website.

After you downloaded the packages follow the Canon installation guides:

I recomend using the method Installing the ScanGear by specifying the package, since you seem to have trouble with the common package.

share|improve this answer

This is what I did. I use Ubuntu 12.10 64 bit, and have absolutely zero knowledge in Linux... or anything to do with IT actually. So for those of you who are as lost as I was a few minutes ago, and can't seem to work it through Terminal, I hope this will help.

  1. I went to, navigated forward with my preferences (I live in Sweden), chose "Software (drivers and applications)" (translated it from Swedish. It should say something similar in English) and then clicked on "MP230 series IJ Printer Driver Ver. 3.80 for Linux (rpm Packagearchive)" and downloaded the file.
  2. I extracted/decompressed the file.
  3. I opened the extracted file and then opened "packages".
  4. I right-clicked on "cnijfilter-common_3.80-1_amd64.deb" and chose "Open with Program Central for Ubuntu" (assume it says something similar in English).
  5. I installed it.
  6. I did the same thing with the package "cnijfilter-mp230series_3.80-1_amd64.deb".
  7. Finally I simply added the printer in System Settings and voilà!
share|improve this answer

"Error: Dependency is not satisfiable: scangearmp-common (>= 2.00), ". Did you install the "-common" file first?

If you are on AMD64, then select the respective amd64 package. First install "-common" file: scangearmp-common_2.00-1_i386, then follow by scanner file: scangearmp-mp230series_2.00-1_i386.

You can install either through ./ or simply click on it and let the package installer take care of it.

After installing, to use scanner I started the GIMP and access the scanner via Ffile -> Create -> Scangear MP

I tried xsane and simplescan, both did not work. On the Canon scangear manual for Linux, it says, only GIMP can start the scanner.

Here is the scanner operation manual:

Hope this help.

share|improve this answer

I installed these and it worked just fine after... 
share|improve this answer

Had the same issue. I downloaded this and this, then used the Archive Manager to extract them. Then I got to the extracted folder in Terminal and used sudo ./ or sh, whatever worked. Then I ran the command scangearmp in Terminal to load the scanning software (sadly it doesn't seem to work with Simple Scan).

share|improve this answer

protected by Community Mar 5 '14 at 16:33

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.