Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I bought a used nvidia 7800 gtx card and plugged it in to the motherboard and then plugged the monitor into the the vga portion of a dvi to vga converter located in the back of the card. I booted up and got a 640x480 resolution. I then attempted to install the nvidia 304.37 driver. I now know that this driver has been updated to 304.64. Anyway, I installed the 304.37 driver, restarted the computer, the screen went white and black then dropped me to a command prompt.

I have since uninstalled that driver, reinstalled 304.60, 304.64, and attempted a couple of others -- all of which were unsuccessful. The furthest I have been able to get thus far is the 'ubuntu' picture showing when the operating system is loading.

I have googled this for a while now and some other things I've tried are sudo apt-get install nvidia-current nvidia-settings, sudo apt-get install nvidia-current-updates, sudo apt-get install nvidia-experimental-304, searching the kernel log file for hints (I read it could be an issue with nouveau but found nothing in the log files about noveau). I did find in the log files this:

     NVRM: Your system is not currently configured to drive a VGA console
     NVRM: on the primary VGA device. The NVIDIA Linux graphics driver
     NVRM: requires the use of a text-mode VGA console. Use of other console
     NVRM: drivers including, but not limited to, vesafb, may result in
     NVRM: corruption and stability problems, and is not supported.

So me not being able to boot into the gui only happens when the monitor is plugged into the card. I'm able to boot into the gui (lightdm I believe?) when I have the monitor plugged into the on-board graphics though * however, I'm only able to get 640x480 resolution now and that is the only resolution available to me *.

My main concern is getting the video card to display the gui, after that I'll work on the resolution problem. Unless the resolution not displaying all the possible values IS the problem. But I don't know what the problem is, which is why I came here. So anyone who might know anything about this feel free to post some things to try. I'm pretty new to linux and ubuntu so don't rule out me not getting something obvious.

share|improve this question
add comment

1 Answer

Remove the existing driver Codes: sudo apt-get update sudo apt-get purge nvidia-current sudo apt-get purge nvidia-current-updates

Installing NVIDIA driver Codes: sudo apt-add-repository ppa:ubuntu-x-swat/x-updates sudo apt-get update sudo apt-get install nvidia-current

Then restart the computer and do this: Code: nvidia x server settings

If "nvidia: command not found"

Try Code: nvidia-settings

Done!

share|improve this answer
    
After purging the existing codecs, adding the repository, running those sudo apt-get commands and restarting I came across another white screen of death so I restarted again and typed nvidia x server settings and got eh command not found error. Then I type nvidia-settings and I get this error: ERROR: The control display is undefined. Please run nvidia-settings --help for usage information –  alexr1090 Jan 10 '13 at 16:37
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.