Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I bought an Asus G75VW. It has the new UEFI BIOS instead of the old style BIOS (1980's) and has Windows 8 preinstalled.

I cannot get the G75VW to install Ubuntu 12.10 in EFI mode. I did get Ubuntu to load if I changed the BIOS to CSM and the computer sees and installs Ubuntu in "legacy mode". I attempted boot repair, and Ubuntu will load after 1 minute but as legacy BIOS only. If I changed the BIOS to UEFI "Binary is whitelisted" is displayed and I get a purple screen.

I want to keep my preinstalled Windows 8 on internal drive bay 1 and install Ubuntu 12.10 on internal drive bay 2, and have the option of booting either one in grub.

I am a software programmer, but I am very bad at understanding BIOS and partitioning.

share|improve this question

1 Answer 1

The purple screen you mention indicates that you've probably booted GRUB 2, but something has gone wrong in loading the kernel or in its early stages of execution. You might be able to find out what's going wrong by changing the boot options to produce a traditional text-mode startup display, but to do that you'll need to get a GRUB menu rather than have it start Linux automatically. IIRC, you can do this by holding the Shift key as GRUB comes up, but I'm a bit foggy on that. This won't solve your problem per se, but it may help you to better diagnose it.

Some other ideas, which are all more shot-in-the-dark type attempts at repair:

  • You can try using the Ubuntu Boot Repair tool, which can fix some boot problems automatically. Be aware, though, that it takes over the Windows boot loader's slot, which can cause confusion or problems down the road.
  • You can disable Secure Boot. This might help because Ubuntu's Secure Boot support is so new and appears to still contain bugs. It's conceivable, but far from certain, that your problems are related to Secure Boot, so disabling it might help.
  • You can try installing rEFInd. I recommend doing this from your legacy/BIOS-mode install of Ubuntu. Using rEFInd will require either disabling Secure Boot or installing another version of shim, which is a bit tedious. Using rEFInd gives you two possible ways to recover:
    • rEFInd can boot a Linux kernel using its own built-in EFI stub loader, which might work better than the way GRUB launches it. Even if it doesn't, you can press the Insert key when you select the Ubuntu (or Linux penguin) icon to get a submenu of options, one of which produces the verbose text-mode boot messages I described earlier.
    • If you edit refind.conf, uncomment the scanfor line, and add hdbios to the list of options, rEFInd might give you a BIOS-mode boot option that will enable you to boot Linux in BIOS mode (via a BIOS-mode GRUB) even while Windows boots in EFI mode. This isn't 100% optimal, but it might be good enough.
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.