Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

So,

I have a Sony Vaio sve15118fg running Ubuntu 12.10 which comes with an AMD Radeon™ HD 7650M graphics chip.

This was all working fine until some updates (note sure what they were) came through, after installing my laptop now no longer boots properly, specifically:

  • Upon attempting to boot the screen starts flicking violent striped horizontal lines. This can only be corrected via the power button.
  • Attempting to do anything in recovery - bar dropping to a root shell - runs fsck which ends up hanging (although the system still responds there is no HDD activity). This is remedied via Ctrl+Alt+Delete to restart the system.
  • Running fsck manually from the root shell completes successfully.

I have attempted numerous things including removing all propriety drivers, Trying the two installed propriety drivers, installing the latest beta driver from AMD. etc.

These all yeild various results, such as the same as above, or a gnome-fallback session, or a gnome-shell session with various flickers and graphical artifacts.

So, I am wondering, what the heck do I have to do to get this to work?!? I don't really game, especially in ubuntu, so I just want a working system! not fussed about 3d acceleration of whatever...

share|improve this question
    
Little update: for the open-source driver it's a kernel issue.<br /> Please refer to this Launchpad bug entry: Launchpad bug 1123024.<br /> It would be very useful if you report that the bug affects also you on that page (in order to boost the bug's priority). –  marcomurk Mar 12 '13 at 17:30
add comment

4 Answers 4

Try http://support.amd.com/us/kbarticles/Pages/AMDCatalyst1211betadriver.aspx. I was able to get this beta driver to work successfully with a Radeon HD video card running Ubuntu 12.04. Had similar problem with an ASUS box before installing this driver.

share|improve this answer
add comment

I'm having exactly the same problem with a Vaio SVE1512 with HD7650M... Still didn't find the way to get rid of the problem (have you found one?).

However discovered a dirty workaround for the open-source radeon driver: boot the machine and wait for the screen to start flickering. At this point close the laptop lid and wait about 10s for the system to enter sleep/standby mode. Then open laptop lid and resume the pc from sleep/standby. Now there should be no flickering problem until next system boot.

p.s.: note that, after resuming from sleep/standby, there's no problem at all (even with 3d games like extremetuxracer) until next boot

share|improve this answer
add comment

I have found this thread but haven't used it myself yet, will do a week later and repost Brightness controls are not working in sony vaio with amd radeon hd 7650

share|improve this answer
1  
Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. –  Kevin Bowen Jul 9 '13 at 3:41
add comment

The solutions is to have Ubuntu 12.04.3 or 13.10 (recommended) then do the following:

sudo apt-get install fglrx fglrx-pxpress

Then: sudo amdcccle and set the graphics to intel graphics :)

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.