Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am using windows 8 and Ubuntu 12.10 and the windows 8 machine is setup as a SMB share. I have read through the man page for cifs-mount, but now matter what I try, I cannot get the share to give me read and write access to the server. Ubuntu will not let me install smbfs as it is obsoleted, so I am unsure where to go from here. The command I am using is

//theip/Users /media/folder cifs domain=domain,username=user,password=secret,uid=me,rw

Thank you!

share|improve this question

2 Answers 2

up vote 1 down vote accepted

I must've been very tired when I was dealing with this. I just checked again and the command seemed to work fine when I changed it to

//theip/Users /media/folder cifs domain=domain,username=me,password=mypass,uid=1000,iocharset=utf8,codepage=unicode,unicode 0 0

I found this on this page: https://wiki.ubuntu.com/MountWindowsSharesPermanently

share|improve this answer

Using Ubuntu 12.10, and connecting to a NAS smb share. I'd like to clarify that simply adding uid and gid seems sufficient. I had the following entry in my fstab:

//server_name/share_name  /mount_point  cifs  user=user_name,password=pass_word,rw 0 0

When I would right-click, the options for Create New Document and Create New Folder were greyed out. I could open files, but only Save As was available if I edited, and trying that would throw a permission error.

I added the following after my password:

uid=my_uid,gid=my_gid 

I was then able to edit the files and create folders as normal.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.