Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have an Ubuntu Server running on 12.04.1 LTS with the GUI installed too. My server has an internal gigabit ethernet card which is configured to serve a web app on a Public IP. At this point I did not have any issues. The web app loads perfectly from any computer in the web. I do have the problem that I cant access the internet from the server itself, I open the web browser and does not load, but yet the server is accessible from the web, maybe this is a configuration from my ISP, Ive been looking for an explanation but still havent found one. Maybe here I cant get an appropiate answer.

Anyways, thats not the real problem. The problem is that I need to load a lot of data to the webapp, and I would like to do it locally through the LAN. So I installed a Wifi usb dongle. It worked perfectly, now I can get internet on the Server and access it locally. But now my public ip wont load the webapp.

The USB dongle is connected to a Wireless Router which has access to the internet. My ethernet card is connected to a switch provided by my ISP where I connect my other servers to get a Public IP. They gave me the range of IPś and told me I just had to configure my server with the public ip I wanted and leave it static, and it worked fine until y installed the USB dongle.

Here is my configuration on /etc/network/interfaces

auto eth0
iface eth0 inet static
address 190.109.197.---
netmask 255.255.255.---
gateway 190.109.197.---

I would appreciate your help so much.

share|improve this question
1  
What is in your /etc/resolv.conf? Can you rresolve network names (host askubuntu.com)? can you ping your gateway? –  qbi Jan 17 '13 at 13:23

1 Answer 1

Right below 'gateway' add a new line:

dns-nameservers 8.8.8.8 190.109.197.<suffix of gateway>

Restart eth0 and you should be able to connect:

sudo ifdown eth0 && sudo ifup eth0
ping -c3 www.google.com
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.