Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

So when running sudo apt-get update i get errors:

Err http://ppa.launchpad.net quantal/main amd64 Packages
  404  Not Found
Err http://ppa.launchpad.net quantal/main i386 Packages
  404  Not Found
W: Failed to fetch http://archive.canonical.com/commercial-ppa-uploaders/skype/ubuntu/dists/quantal/main/binary-amd64/Packages  404  Not Found [IP: 91.189.92.191 80]

W: Failed to fetch http://archive.canonical.com/commercial-ppa-uploaders/skype/ubuntu/dists/quantal/main/binary-i386/Packages  404  Not Found [IP: 91.189.92.191 80]

W: Failed to fetch http://ppa.launchpad.net/cooperjona/stormcloud/ubuntu/dists/quantal/main/binary-amd64/Packages  404  Not Found

W: Failed to fetch http://ppa.launchpad.net/cooperjona/stormcloud/ubuntu/dists/quantal/main/binary-i386/Packages  404  Not Found

E: Some index files failed to download. They have been ignored, or old ones used instead.

Because of that update manager always popus up message that i should check my internet connection. So what do i do? How do i remove this packages?

Btw the skype problem started from the moment i tried installing skype from USC.. I ended up installing skype by deb file but having this problem from then...

Also my etc/apt/sourced.list.d doesn't have a skype file or a subfolder..

Ubuntu 12.10 here

share|improve this question
add comment

1 Answer

up vote 6 down vote accepted

I recommend first to comment out or remove those 2 PPA which are not part the official repositories and are the ones giving you an error.

First install ppa-purge which is in the proposed repositories in case you don't see it:

enter image description here

If you don't have the proposed repositories enabled, you will not be able to do it with the error you have right now, so for the moment you will need to do the following:

  1. Open the DASH and type sources, it should show you Software Sources. Open it and go to the Other Software tab. It should look something like the following image:

    enter image description here

  2. Start removing/disabling any PPA you do not need apart from the ones that gave you an error which were:

    http://archive.canonical.com/commercial-ppa-uploaders/skype/ubuntu/dists/quantal/main/binary-amd64/Packages

    http://archive.canonical.com/commercial-ppa-uploaders/skype/ubuntu/dists/quantal/main/binary-i386/Packages

    http://ppa.launchpad.net/cooperjona/stormcloud/ubuntu/dists/quantal/main/binary-amd64/Packages

    http://ppa.launchpad.net/cooperjona/stormcloud/ubuntu/dists/quantal/main/binary-i386/Packages

    If you click on any of this links you will get as 404 error which means the source moved to another planet (It is gone!!). So look for this in your Other Software tab and remove them. After that remember to activate the Proposed repository and simply close Software Sources.

  3. Now go to a terminal and: sudo apt-get update.

It should work now, if not, look at the error message and remove any following PPA that gives you trouble.

share|improve this answer
    
The problem is that skype and stormcloud are not listed in other software.. i am sure about it... –  Leon-TastyDev Jan 10 '13 at 13:14
    
I fount the stormcloud thing (i.imgur.com/5JbWU.png) and disabled it.. That error fixed.. What about skype now? I want skype installed in my system and also to be able to update my system.. –  Leon-TastyDev Jan 10 '13 at 15:17
    
@Leon-TastyDev - Just disable the PPA for skype and use the Skype found in Software Center. Ubuntu in 12.10 has the latest version of Skype. –  Luis Alvarado Jan 10 '13 at 17:13
    
1) Skype ppa is not listed in the "Other software", 2) ppa-purge ppa:skype gives the error "Warning: Could not find package list for PPA: ppa:skype ppa:skype" , 3) i just removed skype from synaptic, same error when trying to update –  Leon-TastyDev Jan 10 '13 at 23:52
    
what you left with then is discarding all ppa and start adding each one and testing until you find the one –  Luis Alvarado Jan 11 '13 at 3:01
show 1 more comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.