Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I normally try to figure things out on my own, but I'm at a loss now.

Although I've used Linux for almost a year now, I'm still sort of a newbie.

I run Xubuntu 12.04 on a desktop, and I have a Radeon HD 5430 video card.

Till recently I've been using the proprietary FGLRX driver listed in the "additional drivers" menu, and it's been working mostly fine, unfortunately most games in the Steam Beta are still not working.

Today there was a driver update available, it's called "Experimental AMD binary Xorg driver". I ran that, and suddenly the Steam games are working fine, which is awesome, but now my computer has the "AMD unsupported hardware" watermark in the lower right.

So, as per this solution: How-to remove "amd unsupported hardware" without reinstalling the driver? I made the text file and ran it. The watermark was still there, so I rebooted, and my computer only came up to a blank screen with the error message "could not write bytes: broken pipes." that was the only message, and I couldn't type anything, or do anything with the keyboard at all.

So I rebooted again, started in Ubuntu recovery mode, managed to get to a command line and ran "sudo apt-get install fglrx-updates", which reinstalled the original video driver and my computer starts fine again, but I'm back to the original scenario where my graphics card doesn't properly run steam.

So far my only solution is that when I want to play games, I'll activate the new driver, reboot, and just deal with the watermark, then activate the old driver and reboot again when I'm done...but obviously that is not ideal.

Sorry this was kind of long. I know this new driver is still unstable/beta, but other than the watermark, it's working fine. Is there a reason the solution to get rid of the watermark isn't working on my system?

Any advice would be great. Thanks !

share|improve this question
This is happening to me as well on Ubuntu 12,04. Its a real pain. I am running a HP Pavilion laptop with switch-able graphics. The new driver works but I can't get rid of the warning overlay. –  user130332 Feb 11 '13 at 21:40
See solution at askubuntu.com/a/285169/9108 –  Subhash Apr 25 '13 at 1:32
add comment

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.