Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I want to be able to run openbox as my window manager while running GNOME.

If I install openbox, I get the additional choices at the GDM login window of a 'GNOME/Openbox' and an 'openbox session'. If I log in with the 'openbox session', it starts openbox successfully. However, if I log in using the 'GNOME/Openbox' session so that I can run GNOME but just replace metacity with openbox, I find that openbox does not start, and that metacity is managing my application windows.

It looks something is not working in the GNOME/Openbox session in 10.04 (and possibly other versions of Ubuntu).

I know that I can manually replace metacity with openbox by typing 'openbox --replace', but I want to know the correct way of starting openbox in a GNOME environment automatically at logon.

share|improve this question

3 Answers 3

up vote 1 down vote accepted

The GNOME/Openbox session will work if you edit the file /usr/share/applications/openbox.desktop and add the following line:

X-GNOME-Provides=windowmanager

At the next login, GNOME will start with openbox as the window manager instead of metacity.

share|improve this answer

Setting the GConf key /desktop/gnome/applications/window_manager/default to "/usr/bin/openbox" (or where ever that binary is) makes Openbox the default window manager for your Gnome session.

share|improve this answer
    
Florian, while this does start openbox when I log in, it does it for both the "GNOME" session and the "GNOME/Openbox" session. Additionally the "GNOME/Openbox" session uses 100% CPU (although top does not seem to clearly indicate what is causing this). I also note that gconf-editor reports that editing this key has been "deprecated since GNOME 2.12". Is there a more robust solution that allows me to switch between "GNOME" and "GNOME/Openbox" at login without having to edit a gconf setting? –  user8979 Feb 1 '11 at 21:18

Perhaps I misunderstand, but afaict, the correct way is to use the "GNOME/Openbox" session.

I think you need a new question, along the lines of: "Why does my GNOME/Openbox session use 100% CPU?".

share|improve this answer
    
Thanks, djiekyb, but when I log in using the GNOME/Openbox session, metacity is running as the window manager. –  user8979 Feb 13 '11 at 20:32
    
Sorry, that was dumb. Misunderstood you. –  djeikyb Feb 14 '11 at 11:09

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.