Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Update manager fails with a dialog box that says

W: GPG error: http://ppa.launchpad.net lucid Release: The following signatures  
   couldn't be verified because the public key is not available:  
   NO_PUBKEY 5126890CDCC7AFE0

I have tried a few "solutions" to this. The next step is always to add a key to the keyring. Whenever I try

~$ gpg --keyserver pgpkeys.mit.edu --recv-key 5126890CDCC7AFE0  
       gpg: requesting key DCC7AFE0 from hkp server pgpkeys.mit.edu  
       gpgkeys: HTTP fetch error 7: couldn't connect to host gpg:  
       no valid OpenPGP data found. gpg: Total number processed: 0 

~$ gpg --keyserver keyserver.ubuntu.com --recv-key 5126890CDCC7AFE0  
       gpg: requesting key DCC7AFE0 from hkp server keyserver.ubuntu.com  
       gpgkeys: HTTP fetch error 7: couldn't connect to host gpg:  
       no valid OpenPGP data found. gpg: Total number processed: 0 

that, I get the error message

HTTP fetch error 7: couldn't connect to host

This error seems to be associated with connecting to the internet through a proxy server. However, I am connected directly to the internet.

What am I missing?

Thanks Fred

share|improve this question
    
Please tell us the commands that resulted in that error. –  guntbert Jan 9 '13 at 19:43
    
you can always edit your question, and then please remove those two comments :) –  guntbert Jan 9 '13 at 19:53
    
OK. I'm new here so I don't know the rules. It looks like you edited the question for me. Thanks. Is this OK now? –  Fred Brehm Jan 9 '13 at 20:00
1  
Sure, it is not so much about "rules" but about making it easy for everyone to participate, to understand the question and later on a (hopefully) sensational answer ;-) –  guntbert Jan 9 '13 at 20:02
    
Please accept Robie's answer if it solved your problem - we need to find good answers. –  guntbert Jan 9 '13 at 21:23
add comment

1 Answer

Looks like you're using a PPA (personal package archive). These make packages available to you that aren't part of Ubuntu.

If you don't want this, you can disable the PPA by looking in /etc/apt/sources.list and/or /etc/apt/sources.list.d for the appropriate entry, and either removing or commenting it out. Then Update Manager should work correctly again.

If you do want the PPA enabled, then the easiest way to fix the problem is to remove the entry as above, and then adding it again using the add-apt-repository command. This command both adds the PPA and automatically and securely retrieves and enables the correct key.

Alternatively, you can get the key from here. Save that (the part including and between BEGIN PGP... and END PGP...) to a file and import it using sudo apt-key add <filename>. But note that this method is not secure, since you are retrieving the key over an unencrypted channel.

share|improve this answer
    
Thanks, @RobieBasak. I found a file –  Fred Brehm Jan 9 '13 at 20:24
    
That was incomplete and I'm trying to learn the markdown stuff. 5 minutes wasn't enough.... Thanks, @robie. I found a file /etc/apt/sources.list.d/eclipse-team-debian-package-lucid.list and commented out the contents. Then update worked. I'll leave it alone for now, but I might need to fix it the next time I update the Android support in Eclipse (or whatever it came from). –  Fred Brehm Jan 9 '13 at 20:34
    
It turns out that the fundamental problem was that the corporate firewall blocks port 11371. –  Fred Brehm Jan 14 '13 at 14:03
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.