Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Possible Duplicate:
How to Install Broadcom / STA Wireless card (BCM43XX)

I installed Ubuntu 10.10 onto an older Dell Latitude D520 (it's the only disc I had till I connected to the net, and grabbed the newest distro) and the wireless drivers installed and connected just fine.

I first tried the easy route (upgrading to 12.10 through Update Manager) but it errored out and would not let me update/upgrade. so I just downloaded the ISO and tried to install it via disc. but this time, the wireless will just not work for me. (after much diligence) I finally found the new Software Center that contains the Additional Drivers program. it says that I am using the Broadcom 802.11 Linux STA wireless driver source from bcmwl-kernal-source (proprietary). but my wireless light will not turn on after hitting the "fn+wireless button" and in my network finder it only says "Wired Network - Disconnected" it doesn't list anything about Wireless. it doesn't say "wireless disabled" or "wireless disconnected". it just shows status for wired connections.

I've tried this with 12.10, 12.04, 11.10, 11.04, and 10.10 is the latest distro that allows me to use wireless. and because it's so out of date, it will not update/upgrade at all. my other major setback, is I do not have any ethernet at my disposal at the moment. I cannot connect to my router aside from my wireless signal. so updating my repositories doesn't work either.

if there is anything I can do, I would love to know. I am fairly computer savvy, but most of my skill is in windows.

Thanks in advance.

share|improve this question

marked as duplicate by Luis, Takkat, Chris Wilson, Ringtail, Eric Carvalho Jan 10 '13 at 0:47

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
It possibly is a duplicate indeed. In addition to installing firmware referenced in Luis' link, you will also need to remove the STA driver: sudo apt-get remove --purge bcmwl-kernel-source. –  chili555 Jan 9 '13 at 19:55

1 Answer 1

open the ‘Synaptic Package Manager‘ (if you are using Ubuntu 11.10 then install it first from the software cemter) and search for ‘bcm’ uninstall the ‘bcm-kernel-source‘ package make sure that the ‘firmware-b43-installer‘ and the ‘b43-fwcutter‘ packages are installed type into terminal:

cat /etc/modprobe.d/* | egrep '8180|acx|at76|ath|b43|bcm|CX|eth|ipw|irmware|isl|lbtf|orinoco|ndiswrapper|NPE|p54|prism|rtl|rt2|rt3|rt6|rt7|witch|wl' 

see if the term ‘blacklist bcm43xx‘ is there

if it is, then type cd /etc/modprobe.d/ and then sudo gedit blacklist.conf put a # in front of the line: blacklist bcm43xx then save the file (I was getting error messages in the terminal about not being able to save, but it actually did save properly). reboot

Source: http://www.computerandyou.net/2011/05/how-to-solve-no-wireless-networks-in-ubuntu-11-04/

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.