Sign up ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

I have an bluetooth headset connected to my computer, the buttons play/pause/volume are working fine, but i have no sound in the headset, but in the speaker of the computer. In fact i played with the sound settings of my headset in the sound settings of ubuntu, and after choosing "switch off", the headset did "disapear" from the settings. My question is, how can i make it appear there again, to be able to hear the sound via the headset? Thank You all for help.

share|improve this question
Did you check sound settings and confirm the correct 'output' is selected? For some more setttings I would advice to install pavucontrol. It saved me some troubles diagnosing sound issues. – Rinzwind Jan 9 '13 at 21:07
Yes, that's it, it works, THANK YOU VERY MUCH. I found the headset in pavucontrol and was able to turn it on again - it was not visible in the "sound settings" after i did choose the "switch off" profile - that is to correct by ubuntu i guess. Thank You again. – imago Jan 9 '13 at 21:32
Here you go @imago :) Glad it worked out! – Rinzwind Jan 9 '13 at 21:42
Already answered this exact duplicate q: Accidentally changed Bluetooth mode to off – gertvdijk Jan 9 '13 at 21:46
possible duplicate of Accidentally changed Bluetooth mode to off – Eliah Kagan Jan 10 '13 at 0:07

4 Answers 4

For some more settings I would advice to install pavucontrol. It saved me some troubles diagnosing sound issues. It also will list any possible output where Ubuntu sound sometimes forgets to show outputs that should be available (though it keeps getting better: HDMI used to not show up; 1 update after 12.10 release it started showing up.

You too will be able to find your headset and control it from here.

If I recall correctly after I used pavucontrol to activate my hdmi ubuntu control picked it up too (but that might have been caused by an update too). Otherwise do not use Ubuntu sound settings but switch to this program since it also has far more options.

enter image description here

Command line install

sudo apt-get install pavucontrol

or hit the button ...

Install via the software center

share|improve this answer
The bluetooth device doesn't show up as an output. That's the problem... – Cerin Jul 3 at 2:07

if not already installed install pulseaudio-module-bluetooth, this will add the required pulse audio sink that is needed.

sudo apt-get install pulseaudio-module-bluetooth

Then make sure in the bluetooth manager your headset is connecting to the audio sink. At this point it should also appear in pacucontrol, make sure it uses the high quality audio protocol.

share|improve this answer

I am relatively new to the Linux world, but have had no major issues converting from Windows. Please be patient with my explanation because I wrote it with a brand new person to Linux in mind. I have fallen in love with Linux and wish for other "newbies" to do the same :)

For someone converting from windows... powerful "sudo" commands that are entered without understanding of their meaning... may quickly lead to a fresh re-install of one's favorite flavor of Linux. I speak from experience. If you are new to Linux, especially switching from Windows, it is important to know that not all hardware is compatible and to make it even more interesting, Linux “distros” are also not equal. I am currently using Linux Mint 17.1 KDE, which is more or less a derivative of Canonical's Ubuntu. For example, if you didn't know, most HP printers are recognized immediately and effortlessly within Linux because of the the wonderful HPLIP opensource project. Just connect and turn on your HP printer, then go to printer settings within Ubuntu or Linux mint 17.1 and simply add your HP printer (which should be already listed).

A little research first will definitely save a huge headache later. :)

I tried using my Insignia Bluetooth Receiver in the past, but had no luck on Mint or Ubuntu, while my newly bought Kensington Bluetooth 4.0 dongle #K33956AM was recognized and paired seamlessly with my other devices. It was able to list the exact device name along with the MAC address. Unfortunately, I had NO SOUND. :( I double checked it was not my system. My computer played the music file normally though my built-in analog stereo hardware. :(

I read what the awesome and helpful people stated above, but went though the graphical interface instead of using the terminal (I've used windows for the past 20 years, what can I say... LOL) I went to System Settings/Multimedia/Audio and Video Settings and discovered my Analog stereo hardware received priority over my Bluetooth hardware. I first attempted to change the priority of the devices within the "Audio Playback Device Preference for 'Music' Category" but this did not fix my sound.

THEN I DISCOVERED THE SOLUTION TO MY PROBLEM... I changed the priority of devices in the "Audio Playback Device Preference for 'Video' Category" and BINGO!!! :) :) :) This worked perfectly. For some reason the video setting also controls the music. I changed all pertinent settings to make my Bluetooth have priority and have not had any further issues since that point. Hope this helps. :)

Pulse Audio Volume Control is Pre-installed on Linux Mint 17.1 (. This is a great tool. Just search in the menu bar for the program or use the PPA from the repository a.k.a. Software Manager. Although I should mention, this program would not work for me until after I changed the settings in the Multimedia.


share|improve this answer

Thanks CPlovlin, this is the one last config step I was missing. My Bluetooth headset works much better in Debian than in Windows 10. I had short range when using Windows and it cut out a lot. In Debian Jessie, I have nearly double the range.

For others using Debian or Ubuntu. Here is what I did to get my Bluetooth dongle to work and my headset configured.

1.) First I plugged my USB Bluetooth Dongle into my computer. After that I did a quick check to see if it was recognized.

sudo lsusb

2.) Open up terminal, you will need to install a few things.The following meta-package has most of what you will need. Don't forget sudo or su.

sudo apt-get install bluetooth

3.) Now we need an applet in the tool bar at the bottom. For KDE, I did this (if you are using a different window manager, you may wanna look for whichever will work best for you:

sudo apt-get install bluedevil

4.) I then had to add the blue tooth software to get the volume control to have the bluetooth modules needed.

apt-get install pulseaudio pulseaudio-module-bluetooth pavucontrol bluez-firmware

5.)After that, you should just probably do a quick reboot. Do either of the following: sudo reboot


sudo systemctl restart bluetooth

You should have a bluetooth icon in your system tray. Now just right click and choose 'Add Device'

Now that your bluetooth is all set up, make sure to follow what CPlovin said above. Just because your testing out an mp3, make sure that your headphones are the preferred device for video and audio. I just set it to be my preferred device for everything.

Hope this helps others!

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.