Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Preface

I have downloaded the latest AMD/ATI drivers for my Radeon HD 7850 and I am having a difficult time getting it to work with ATI Stream SDK 2.1.

I have tried purging fglrx and installing from debs created from the Catalyst installation script. I have also tried simply installing directly from the script, vs generating and installing .debs. After every installation, I run sudo aticonfig --initial --nobackup and then reboot my system.

Problem

The problem I am having is that fglrxinfo is giving me this error: Error: unable to open display (null). I have run fglrxinfo with my DISPLAY variable set to both :0.0 and :0 with no success.

Also, DISPLAY=:0.0 ./CLInfo only returns my CPU and no GPU. My goal is to install my graphics card and have it shown in CLInfo so that I can use it for OpenCL.

System Information

$ lspci -nn | grep VGA
01:00.0 VGA compatible controller [0300]: Advanced Micro Devices [AMD] nee ATI Device [1002:6819]

$ uname -a
Linux Ubuntu-12.04 3.2.0-35-generic #55-Ubuntu SMP Wed Dec 5 17:42:16 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

$cat /etc/X11/xorg.conf
Section "ServerLayout"
    Identifier     "aticonfig Layout"
    Screen      0  "aticonfig-Screen[0]-0" 0 0
EndSection

Section "Module"
EndSection

Section "Monitor"
    Identifier   "aticonfig-Monitor[0]-0"
    Option      "VendorName" "ATI Proprietary Driver"
    Option      "ModelName" "Generic Autodetecting Monitor"
    Option      "DPMS" "true"
EndSection

Section "Device"
    Identifier  "aticonfig-Device[0]-0"
    Driver      "fglrx"
    BusID       "PCI:1:0:0"
EndSection

Section "Screen"
    Identifier "aticonfig-Screen[0]-0"
    Device     "aticonfig-Device[0]-0"
    Monitor    "aticonfig-Monitor[0]-0"
    DefaultDepth     24
    SubSection "Display"
        Viewport   0 0
        Depth     24
    EndSubSection
EndSection
  • Ubuntu 12.04 (Server)

References

share|improve this question

1 Answer 1

up vote 1 down vote accepted

I was able to get everything working by installing a lightweight X Window system.

sudo apt-get install lxde

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.