Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm working on a new Latin-based script for Persian. So I've used such lines in GB locale file, to modify the sort order:

First of all, I've introduced the new characters in such way:

collating-symbol <acirc>

Then, defined the order:

reorder-after <a> <acirc>

And, finally the unicode:

reorder-after <U0041> <U00C2> <acirc>;<CIR>;<CAP>;IGNORE % Â

But, after I save the file, and run the command sudo dpkg-reconfigure locales, nothing is changed, and the applications such as Text Editor or LibreOffice Writer don't obbey the new-defined order.

Should I do more to introduce this new sort order to apps?

share|improve this question
1  
Are you using the locale where you added that? Does it work with simple, commandline UNIX tools like sort? LibreOffice does have the annoying tendency to ignore UNIX settings and suggest that users go use LibO's own regional settings instead. –  njsg Jan 9 '13 at 18:55
    
Oh, of course I'm using it :D – I've changed number formats and weekdays too, and they work perfectly. Also the commandline sort doesn't follow the custom order. Does it mean it's my fault in writing locale? –  AliNa Jan 10 '13 at 0:40
    
@njsg thanks dude! The sort command helped me. I just defined my custom order in en_US to make it work on Terminal. –  AliNa May 13 at 20:55

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.