Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

After having this problem, and following this answer, I have installed AMD Catalyst Control Center (fglrx-amdcccle) and after reboot my display was all wrong, stuck to 1280x1024.

I have un-installed it but could not repair it.

Before all this happened, running lspci -nnk | grep -iA2 vga I got:

01:00.0 VGA compatible controller [0300]: Advanced Micro Devices [AMD]
    nee ATI M24 1P [Radeon Mobility X600] [1002:3150]
Subsystem: Hewlett-Packard Company nx8220 [103c:0934]
Kernel driver in use: radeon

But now i get:

01:00.0 VGA compatible controller [0300]: Advanced Micro Devices [AMD] nee ATI M24 1P [Radeon Mobility X600] [1002:3150]
    Subsystem: Hewlett-Packard Company nx8220 [103c:0934]
    Kernel modules: radeon, radeonfb

For some reason a radeonfb appears beside radeon as kernel driver in use.

How to go back to the previous state?

share|improve this question
add comment

2 Answers

Just uninstall the Catalyst Control Centre. You don't need it in your situation, as it relies on running the fglrx driver. If it pulled in some dependencies and you want them to be gone as well:

Your GPU is supported by the open source driver radeon, which has proper XRandR support so the Ubuntu integrated tool can do all configuration and you have proper KMS support. This is the recommended driver for your hardware, if I'm correct.

The radeonfb kernel module is just part of the regular Linux kernel image and provides very basic framebuffer rendering and communication to the card. I bet if you just remove the CCC and reboot it'll be gone. I suspect the CCC modprobe'd it, but then errored out and didn't bother rmmod'ing it. If it doesn't fix it, try to find what causes it to load (e.g. /etc/modules) or blacklisting it.

For your original issue, you could try to actually completely switch to fglrx (if supported) and see if it helps out like reported in this question:

However, it seems that was not working out for you, so I'm just posting this for other ones bumping into this question later.

share|improve this answer
    
your answer guided me to a solution that i posted as answer. but now the other libreoffice-related issue is back –  cipricus Jan 9 '13 at 17:32
add comment
up vote 0 down vote accepted

As suggested in the gertvdijk's answer, I looked at this question: Google Chrome not rendering webpages correctly which initially was supposed to solve my other problem related to Openoffice. There, I looked at this answer, and took the first two steps from there,

sudo apt-get remove --purge fglrx

sudo apt-get install --reinstall xserver-xorg-video-radeon

which after reboot have restored my LXRandr ability of setting my display.

enter image description here

Now

~$ lspci -nnk | grep -iA2 vga

gives:

01:00.0 VGA compatible controller [0300]: Advanced Micro Devices [AMD] nee ATI M24 1P [Radeon Mobility X600] [1002:3150]
    Subsystem: Hewlett-Packard Company nx8220 [103c:0934]
    Kernel driver in use: radeon

like before the installation of AMD Catalyst Control Center.

(Also, in this way, my Libreoffice problem mentioned above, which had disappeared when this one here emerged, is back. I welcome the kind readers of this post to consider reading my other question and provide an answer that would not produce this problem here again.)

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.