Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have Ubuntu OS and running Windows XP on Virtual Box of Ubuntu as my guest OS.

I wanted to know how can I be able to connect to my guest OS - Windows XP of Virtual Box using tsclient.

When I try to connect using RDP protocol of tsclient I am getting following error message:

enter image description here

Thank you.

share|improve this question
    
Which version of VirtualBox do you use? The OSE (free) or the binary version from Oracle? The latter supports RDP access. –  user4124 Jan 29 '11 at 18:18
    
VirtualBox OSE(free) v. 3.2.1 –  Bakhtiyor Jan 29 '11 at 18:19
    
The OSE version does not have the in-built RDP support. The binary version of VirtualBox supports 1. USB devices and 2. RDP. Therefore, if you insist to use the OSE version, you will have to do some extra work to setup the RDP server on the guest and access from Ubuntu through the internal IP address. –  user4124 Jan 29 '11 at 19:04
    
From Virtual Box 4.0 OSE you need to install the PUEL Oracle Extension Pack: virtualbox.org/wiki/Downloads –  Takkat Jan 29 '11 at 22:09

1 Answer 1

I have same configuration. And I setted my VBox as a (terminal)service, and it runs in background.

This configuration is multi-step, no too easy, if you are a beginner. But I did it...

VirtualBox

Start here, at first, you have to set Network type, to Bridge mode. Look at here, in Attached to: section: bridge mode

Then, your DHCP client will handle your XP as a new computer in LAN, so it will give a new IP to your virtual XP. That IP will be your RDP host. To check that IP, click on network icon near the clock, and the details tab will show your IP, if your DHCP works fine!

XP - guest machine

Here, you should enable RDP server mode and multi user login system, see that tutorial here.

Image example for STEP 5: gpedit.msc

Ubuntu - host system

At first, I give you a method, how can you start your guest machine in background.

Hit [Alt] + [F2], type in: VBoxHeadless -startvm "NameOfVirtualMachine". You may add it to (System > Preferences >) Startup applications.

To check the status, start your VBox controller, and it will display: Running...

If you want to shut it down, you should log in remotely to guest, and right click on task bar(or [Ctrl] + [Alt] + [Del] if it works), then Task manager. In the task manager, you can click on Shut down > Power off; click yes, if it asks you about the restart problem.

Before you connect to your XP, you may play with resolution, settings, sound config, shared drive, not all options will work!

If I forget something, please ask me!

share|improve this answer
    
Thanks a lot. But in the tutorial link you provided about hacking Windows XP, in the step 5 I could not find Computer Configuration > Administrative Templates > Windows Components > Terminal Services parameter in gpedit.msc. It doesn't exist. I did the rest but had no any success. Still having exactly the same problem and getting the same error message. –  Bakhtiyor Jan 29 '11 at 19:54
    
I attached an image, try to find it! You haven't allowed to log in, so maybe after this settings. Sorry it is in Hungarian... –  B. Roland Jan 30 '11 at 14:23
    
Thanks but in my case it finishes with Computer Configuration > Administrative Templates, i.e. there is no Windows Components nor Terminal Services. –  Bakhtiyor Jan 30 '11 at 15:52
    
Have you got XP pro, or home? I think the home hasn't got this feature... –  B. Roland Jan 31 '11 at 2:11
    
I have XP Pro SP3 –  Bakhtiyor Jan 31 '11 at 17:10

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.