Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm using Nvidia 7300 gt and monitor-Acer V173w, on 64 bit Ubuntu 10.04. Compiz and Emerald went well, but at the time of entry into the GUI, I always receive the message :
"Could not apply the stored configuration for the monitor, could not find a suitable configuration of screens"

Why do I always receive it, and what is wrong with the monitor configuration or pci-e is used?

enter image description here

root@dellph1-desktop:/# xrandr
Screen 0: minimum 320 x 240, current 1440 x 900, maximum 1440 x 900
default connected 1440x900+0+0 0mm x 0mm
   1440x900       50.0* 
   1024x768       51.0     58.0     59.0  
   1360x768       52.0     53.0  
   1152x864       54.0     55.0     56.0     57.0  
   960x600        60.0  
   960x540        61.0  
   896x672        62.0  
   840x525        63.0     64.0     65.0     66.0  
   832x624        67.0  
   800x600        68.0     69.0     70.0     71.0     72.0     73.0  
   800x512        74.0  
   720x450        75.0  
   680x384        76.0     77.0  
   640x512        78.0     79.0  
   640x480        80.0     81.0     82.0     83.0  
   576x432        84.0     85.0     86.0     87.0  
   512x384        88.0     89.0     90.0  
   416x312        91.0  
   400x300        92.0     93.0     94.0     95.0  
   320x240        96.0     97.0     98.0  
root@dellph1-desktop:/# 

=== xorg.conf

# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 260.19.29  (buildmeister@swio-display-x86-rhel47-04.nvidia.com)  Wed Dec  8 12:27:27 PST 2010


Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
    Option         "Xinerama" "0"
EndSection

Section "Files"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"

    # HorizSync source: xconfig, VertRefresh source: xconfig
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Acer V173W"
    HorizSync       30.0 - 83.0
    VertRefresh     55.0 - 75.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce 7300 GT"
EndSection

Section "Screen"

# Removed Option "metamodes" " 1440x900_60 +0+0; 1280x1024 +0+0"
# Removed Option "metamodes" "1440x900 +0+0"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "TwinView" "0"
    Option         "TwinViewXineramaInfoOrder" "CRT-0"
    Option         "metamodes" "1440x900_75 +0+0; 1440x900 +0+0"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection
share|improve this question
add comment

3 Answers

Remove ~/.config/monitors.xml.

share|improve this answer
add comment

Removing ~/.config/monitors.xml resolved the error I was getting when logging into my account.

share|improve this answer
add comment

You can't figure out how this how this simple and silly thing can fix an issue like that. But when I faced something like you, what I did is to remove the nVidia drivers, and after a reboot, installed via Envyng, which is fully documented at:

http://albertomilone.com/nvidia_scripts1.html)

I hope you have luck with this as I did sometime.

There are some other solutions, which may include to rename the xorg.conf file to something else in order to allow the system to make a new one, but when I tested that nothing happened.

Just another thing: I hope you are intelligent enough to understand that my suggestion may not fit your solution, but I am sharing with you my experience with the hope that you gather more ideas. Take in consideration before downvoting my answer. Thank you. (at the time that I started this answer, nobody dropped an answer yet, so: good luck!)

BTW: Envyng is not supported for your distribution, but the trick of removing and reinstalling may work. Who knows? give it a try.

share|improve this answer
    
Thank you, because you want to answer questions that might be ridiculous. I have repeatedly reinstalled the nvidia drivers, and it cant fixed the error message I received. Because it does not affect compiz and the need for another display, then I can ignore it, although it was clear something was not right. –  dellphi Jan 30 '11 at 4:08
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.