Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I use a dual boot with two hard disks and two OS is Ubuntu 10.04 and Windows 7. Windows 7 installed on the first disk, first partition. Grub is installed on a second hard disk MBR, and Ubuntu installed on an extended partition on a second hard drive.

When I select Windows 7 on the Grub menu, the HDD lamp lights up briefly and then black screen on the monitor, with the status of the keyboard is still functioning. Until now (with the default boot from first HDD), I have to press F12 to get into the Grub to run Linux on a second HDD.

I want to retain Grub to remain on the second HDD, and Windows 7 could choose from the menu provided by Grub. But I do not get how, I hope anyone can help.

share|improve this question
Can you please try to clean-up your question if you want anybody to figure out what your problem may be (use edit button, use code tags). What is your boot priority in BIOS? – Takkat Jan 29 '11 at 8:25
up vote 2 down vote accepted

I think the source of the confusion is how Grub works. Grub typically attaches itself to the MBR of your hard disk, and it is the hard disk that you have setup in the BIOS to boot first. In addition, you can select that hard disk with F12 as you already have done.

In the MBR there is the starting point for Grub, which then points to a Linux partition that contains the rest of the Grub code. The Grub code resides in the /boot directory.

So what I can guess is that you installed Grub on the MBR second (160GB) hard disk, therefore Grub can only activate when you select to boot from the second hard disk in the BIOS. This might be fine for Ubuntu, but probably messes up with the Windows booting because of drive number changes.

What I recommend is to put Grub/MBR on the first hard disk so that Grub takes over the booting of your computer. Then, you need to make sure that /boot is always accessible. Either the second hard disk is always there, or you can be a pro and create a separate /boot partition (about 500MB) and place it on the first/primary hard disk.

If you do not want to let Grub take over the computer, you can keep the Windows boot manager in charge (but you lose fancy boot options). For this, see

share|improve this answer
Thank you, finally according to your suggestion, I move GRUB to the first hard disk and run as they should. – dellphi Jan 29 '11 at 11:32

There is a trivial fix: EasyBCD by NeoSmart.

  1. It's absolutely free
  2. It can boot virtually anything from virtually anywhere.

I write about it here.

The link to their site.

Go read about it, then download it.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.