Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

A short time after accessing the internet, the browser/download times out. Before the timeout, the internet works OK briefly; afterwards, the wireless is still connected with a strong signal, but every internet access results in a timeout. When I leave the PC for a while, the internet is back just to timeout again as soon as I start using it. The same happens when I reconnect to the router. Also, when I surf the internet, it takes a couple of minutes until the timeout, but when I download something, it times out in a matter of seconds. The wireless adapter works just fine in Windows and internet via ethernet cable works just fine in Ubuntu.

Does anyone have the same problem or knows a solution.

I use Ubuntu 12.10 x64. The problem occurs since I installed ubuntu (which was a few days ago).

Here some stuff that might be usefull:

serus@serus-Ubuntu-PC:~$ lsusb
Bus 002 Device 002: ID 0cf3:1002 Atheros Communications, Inc. TP-Link TL-WN821N v2 802.11n [Atheros AR9170]

serus@serus-Ubuntu-PC:~$ lsmod
Module                  Size  Used by
carl9170               82083  0

serus@serus-Ubuntu-PC:~$ modinfo carl9170
filename:       /lib/modules/3.5.0-21-       generic/kernel/drivers/net/wireless/ath/carl9170/carl9170.ko
alias:          arusb_lnx
alias:          ar9170usb
firmware:       carl9170-1.fw
description:    Atheros AR9170 802.11n USB wireless

serus@serus-Ubuntu-PC:~$ iwconfig
wlan0     IEEE 802.11bgn  ESSID:"virginmedia0137463"  
          Mode:Managed  Frequency:2.462 GHz  Access Point: A0:21:B7:F8:29:B6   
          Bit Rate=240 Mb/s   Tx-Power=20 dBm   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Power Management:off
          Link Quality=66/70  Signal level=-44 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:1399  Invalid misc:18   Missed beacon:0

serus@serus-Ubuntu-PC:~$ sudo lshw -C network
*-network
   description: Wireless interface
   physical id: 1
   bus info: usb@2:2
   logical name: wlan0
   serial: 00:27:19:bb:00:19
   capabilities: ethernet physical wireless
   configuration: broadcast=yes driver=carl9170 driverversion=3.5.0-21-generic firmware=1.9.4 ip=192.168.0.6 link=yes multicast=yes wireless=IEEE 802.11bgn
share|improve this question

2 Answers 2

up vote 2 down vote accepted

Please try a driver parameter:

sudo modprobe -r carl9170
sudo modprobe carl9170 noht=1

If it helps, write one new file:

gksudo gedit /etc/modprobe.d/carl9170.conf

Add a single line:

options carl9170 noht=1

Proofread carefully, save and close gedit.

share|improve this answer
    
noht=1 seems to do the trick. Thanks! Could you please quickly outline what HT does? –  user1622959 Jan 15 '13 at 21:34
    
noht=1 disables 80211n capability. I'm glad it's working. –  chili555 Jan 16 '13 at 3:16

I had a very similar issue with my 'TP-Link TL-WN821N v2' 802.11n usb adaptor. I use Elementary OS, which is based on Ubuntu.

I found a web page somewhere advising someone with the same problem to update their kernel. I decided to do the same on the off chance it worked. I updated the Linux kernel from 3.2.0.54.64 to 3.8.0-32.47, rebooted and found it had completely resolved this issue.

I found this worked too:

sudo modprobe -r carl9170
sudo modprobe carl9170 noht=1

I wanted my my wireless adaptor to work properly in N mode, which it does with no issues at all. Infact even better than it performed on Windows XP.

Hope this may help someone.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.