Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am trying to install Shrew VPN Xubuntu 12.10 and can not compile with cmake. Here is the error I am receiving:

$ cmake -DCMAKE_INSTALL_PREFIX=/usr/local -DQTGUI=YES -DETCDIR=/etc -DNATT=YES
-- Using install prefix /usr/local ...
-- Using etc path /etc ...
-- Using lib path /usr/local/lib ...
-- Using man path /usr/local/man ...
CMake Error at CMakeLists.txt:196 (message):
Unable to locate openssl crypto include files


-- Configuring incomplete, errors occurred!

I am using the latest stable release of shrew VPN.

share|improve this question
    
I have tried this few months ago on 12.04 and there was the same result. A needed library was missing and could not find it. Why don't you install it from software center? –  bob Jan 9 '13 at 14:55
    
I can not find it within the software center. Is there a downloaded .deb package somehwere? –  Spunkybd Jan 9 '13 at 15:47
    
I need shrew in particular because i need to be able to load PCF files. –  Spunkybd Jan 9 '13 at 15:47
    
You need libssl-dev: that will ensure a successful build. See my answer for further information. –  user76204 Jan 9 '13 at 17:59
add comment

1 Answer

Shrew vpn used to be in the repositories under the name ike, so on 12.04 you could install it very simply with sudo apt-get install ike; however this is not possible on 12.10, so one solution would be to compile it.

For compilation you will need the stable release code and the necessary dependencies.

sudo apt-get install build-essential libssl-dev libaudio-dev libcups2-dev 

Note: this will build the command-line client, but not the gui unless you have the qt-dev and toolkit files installed (it requires qt 3.3 or above, but has not been tested with qt4; see the readme with the download for further information).

Now, the configuring with cmake should be fine, and you can specify all the custom options that I see you require when you run it.

This was the successful completion of the configure with the above dependencies installed:

-- Configuring done
-- Generating done
-- Build files have been written to: /home/mike/src/ike

Without libssl-dev installed I get exactly the error you received:

CMake Error at CMakeLists.txt:196 (message):
Unable to locate openssl crypto include files

You can use install and use checkinstall to install the compiled program, or you may have other plans.

share|improve this answer
    
good one Mik... –  bob Jan 10 '13 at 9:36
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.