Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This problem started with a new version of LibreOffice, 3.6.2.2. (the one with the new green splash screen instead of the old white one) and continued up to the latest 4.x versions.

My documents are not displayed properly when I scroll up or down.

The problem appears only above a certain zoom level and is the same in odt or doc.

Example. Have pasted a text here

enter image description here

After scrolling down:

enter image description here

and down:

enter image description here

and then up:

enter image description here

Clicking on the text restores it but it always goes back to the beginning which is the only part that is visible in this way - and larger documents are almost unusable!

The document can be taken under control if the zoom is equal or lower than 180%. It may vary depending on display and resolution, but it seems to me that the problem disappears as soon as the zoom goes down so that the page is largely within the margins of the maximized window.

enter image description here

On my display the comfortable zoom level (the one that I would prefer to use, and cannot) would be 230% (e. g. with 11 Arial).


  • This also affects other parts of the office suite (Calc, Impress).

  • I never had display problems with this laptop before, and previous versions of Libreoffice worked ok.

  • I have tested with a live usb and the same LibreOffice version and the problem appears in the same manner.

  • This happened initially in Lubuntu 12.10, and then in Xubuntu 12.10 too, and in all versions of LibreOffice above 3.5.

  • I am able to use msoffice 2007 under Wine with no problem. To avoid the present issue, I use LibreOffice 3.5.

share|improve this question
2  
@cipricus Just apply system update (selectively) in the Live environment. As long as your RAM can hold the changed compared to the state of the Live CD, this is possible (thanks to SquashFS). –  gertvdijk Jan 9 '13 at 18:47
    
my present solution: downgraded to 3.5 –  cipricus Jun 10 '13 at 7:54
    
i have largely re-edited the question and flagged to re-open –  cipricus Jun 10 '13 at 10:04
    
@cipricus - still reads like a bug - have you reported this both on launchpad - and preferably on the libreoffice bug tracking system/mailing list? –  fossfreedom Jun 10 '13 at 10:07
    
@fossfreedom - hope this stands as a bug report –  cipricus Jun 10 '13 at 10:53
show 3 more comments

closed as off topic by gertvdijk, Luis Alvarado, Eliah Kagan, Ringtail, fabricator4 Jan 10 '13 at 10:47

Questions on Ask Ubuntu are expected to relate to Ubuntu within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.