Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Sometimes my soundcard isn't detected at startup. I use Ubuntu 12.10. It seems like, when my headphones are jagged in at startup, my system can detect my audio card. Then I can unjag my headphones and use my speakers. When starting up with my headpones unjagged, then it can't detect my soundcard. I can't get the same effect by forceloading alsa with "sudo alsa force-reload", I have to do a restart with my headphones jagged in, in order for Ubuntu to detect my sound output. It's just onboard audio, nothing fancy.

At the toppanel, it looks like the sound is just muted. However, I can't unmute it, and when I go into the sound settings, under "output", there isn't displayed any audio devices.

I tried a tip in the terminal with the alsamixer app, disabling automute:

http://www.unixmen.com/2012003-howto-resolve-nosound-problem-on-ubuntu/

That doesn't work. And for some reason, adding the PPA for the dev-version of alsa as suggested in the link above doesn't upgrade alsa.

lspci -nn | grep Audio

00:14.2 Audio device [0403]: Advanced Micro Devices [AMD] nee ATI SBx00 Azalia (Intel HDA) [1002:4383] 04:00.1 Audio device [0403]: Advanced Micro Devices [AMD] nee ATI Juniper HDMI Audio [Radeon HD 5700 Series] [1002:aa58]

Hope you guys can help me out! I have really used time figuring this out myself, but can't for the life of me figure it out.

Thanks in advance

share|improve this question

1 Answer 1

You may try solution here : http://ubuntuforums.org/showthread.php?t=988474. This sound card seems to be badly detected by kernel and/or alsa

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.