Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

For some reason I have discovered that I can no longer edit any of the data I have on my USBs. I was once able to edit it and I am able to edit the data on it on other PCs. I am running 32 bit 12.10 if this detail is required.

share|improve this question

1 Answer 1

up vote 2 down vote accepted

I had this happen to me sometimes, and mostly when I use FAT formatted flash drives.

Can you copy files to it using the terminal, could it be related to this bug?

Most of the times that this used to happen to me, I was able to solve it by plugging it into a Windows machine, and using checkdisk on it (or whatever it was called, haven't used it for a while).

Just realized now, I never tried to use Ubuntu's fsck, and I have no idea why.

share|improve this answer
    
No it isn't that bug as this is the error I receive when I do copy files to it using the terminal: cp: cannot create regular file `/media/brentonhorne/0CF1-B736/jkon.m': Read-only file system –  Brenton Horne Jan 9 '13 at 10:06
    
I used my Windows Vista machine to clean it and it worked so I'll accept your answer, thanks. –  Brenton Horne Jan 9 '13 at 10:10
    
Was going to ask you to try using fsck, but I guess I was too late :p –  Dan Jan 9 '13 at 10:11

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.