Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am trying to format a new hard disk (and a USB-stick) using GParted. After successfully formatting the drive (to ext2, ext4, ntfs, fat16, whatever), GParted tries to reload the partition data and concludes that the partition type is "unknown".

I tried to use testdisk, which also seems to be confused about the state of the drive. It detected a 2GB partition to be 29GB big. Rewriting boot table data, recreating the partition table and others have not worked.

What is there left for me to try?

share|improve this question
    
may be time for a new "stick" –  Ringtail Jan 9 '13 at 5:31
    
@RickGreen-Turbo Really? Never mind the USB-stick, I am trying to do this on a brandnew 320GB HDD. Why wouldn't it work? I am guessing you misinterpreted my title, because surely you aren't suggesting I should just try it on another new hard drive...? –  Earthliŋ Jan 9 '13 at 5:41
1  
Don't know - why don't you edit your question to reflect that issue - I was lead to believe it was a thumb-drive. –  Ringtail Jan 9 '13 at 5:51

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.