Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have the exact same problem as How to force a proprietary driver to load on startup?

but the solution does not work for me.

I have

~$ tail -7 /etc/modprobe.d/blacklist.conf 
install rtl8192cu /bin/false
install rtl8192c_common /bin/false
install rtlwifi /bin/false

blacklist rtl8192cu
blacklist rtl8192c_common
blacklist rtlwifi

and

~$ tail /etc/modules 
# /etc/modules: kernel modules to load at boot time.
#
# This file contains the names of kernel modules that should be loaded
# at boot time, one per line. Lines beginning with "#" are ignored.

lp
rtc
8192cu

but my device

~$ lsusb | grep D-
Bus 002 Device 003: ID 2001:3308 D-Link Corp.

keeps on using the kernel's default driver:

~$ sudo lshw -C network | tail -7
   description: Wireless interface
   physical id: 1
   bus info: usb@2:5
   logical name: wlan1
   serial: 84:c9:b2:75:a1:28
   capabilities: ethernet physical wireless
   configuration: broadcast=yes driver=rtl8192cu ip=192.168.0.19 multicast=yes wireless=IEEE 802.11bgn

instead of the propriety driver:

~$ lsmod | grep 8192
8192cu                547185  0 
~$ modinfo 8192cu
filename:       /lib/modules/3.2.0-35-generic/kernel/drivers/net/wireless/8192cu.ko
version:        v3.4.4_4749.20121105
author:         Realtek Semiconductor Corp.
description:    Realtek Wireless Lan Driver
license:        GPL
srcversion:     657E53E8FE213B566819C54
alias:          usb:v0BDAp8186d*dc*dsc*dp*ic*isc*ip*
alias:          usb:v0E66p0019d*dc*dsc*dp*ic*isc*ip*
alias:          usb:v0846p9021d*dc*dsc*dp*ic*isc*ip*
alias:          usb:v0B05p17ABd*dc*dsc*dp*ic*isc*ip*
alias:          usb:v0DF6p0061d*dc*dsc*dp*ic*isc*ip*
alias:          usb:v20F4p624Dd*dc*dsc*dp*ic*isc*ip*
alias:          usb:v050Dp2103d*dc*dsc*dp*ic*isc*ip*
alias:          usb:v050Dp2102d*dc*dsc*dp*ic*isc*ip*
alias:          usb:v2001p3307d*dc*dsc*dp*ic*isc*ip*
alias:          usb:v4855p0091d*dc*dsc*dp*ic*isc*ip*
alias:          usb:v07AAp0056d*dc*dsc*dp*ic*isc*ip*
alias:          usb:v07B8p8178d*dc*dsc*dp*ic*isc*ip*
alias:          usb:v2019pAB2Bd*dc*dsc*dp*ic*isc*ip*
alias:          usb:v7392p7822d*dc*dsc*dp*ic*isc*ip*
alias:          usb:v0586p341Fd*dc*dsc*dp*ic*isc*ip*
alias:          usb:v2001p3309d*dc*dsc*dp*ic*isc*ip*
alias:          usb:v2001p330Ad*dc*dsc*dp*ic*isc*ip*
alias:          usb:v2001p3307d*dc*dsc*dp*ic*isc*ip*
alias:          usb:v2019p1201d*dc*dsc*dp*ic*isc*ip*
alias:          usb:v04F2pAFFCd*dc*dsc*dp*ic*isc*ip*
alias:          usb:v04F2pAFFBd*dc*dsc*dp*ic*isc*ip*
alias:          usb:v04F2pAFF8d*dc*dsc*dp*ic*isc*ip*
alias:          usb:v04F2pAFFAd*dc*dsc*dp*ic*isc*ip*
alias:          usb:v04F2pAFF9d*dc*dsc*dp*ic*isc*ip*
alias:          usb:v04F2pAFF7d*dc*dsc*dp*ic*isc*ip*
alias:          usb:v13D3p3358d*dc*dsc*dp*ic*isc*ip*
alias:          usb:v13D3p3359d*dc*dsc*dp*ic*isc*ip*
alias:          usb:v0BDAp317Fd*dc*dsc*dp*ic*isc*ip*
alias:          usb:v2019pAB2Ed*dc*dsc*dp*ic*isc*ip*
alias:          usb:v2019p4902d*dc*dsc*dp*ic*isc*ip*
alias:          usb:v4856p0091d*dc*dsc*dp*ic*isc*ip*
alias:          usb:v0BDAp5088d*dc*dsc*dp*ic*isc*ip*
alias:          usb:v0DF6p005Cd*dc*dsc*dp*ic*isc*ip*
alias:          usb:v13D3p3357d*dc*dsc*dp*ic*isc*ip*
alias:          usb:v4855p0090d*dc*dsc*dp*ic*isc*ip*
alias:          usb:v20F4p648Bd*dc*dsc*dp*ic*isc*ip*
alias:          usb:v2019pAB2Ad*dc*dsc*dp*ic*isc*ip*
alias:          usb:v050Dp1102d*dc*dsc*dp*ic*isc*ip*
alias:          usb:v2001p3308d*dc*dsc*dp*ic*isc*ip*
alias:          usb:v103Cp1629d*dc*dsc*dp*ic*isc*ip*
alias:          usb:v06F8pE033d*dc*dsc*dp*ic*isc*ip*
alias:          usb:v0EB0p9071d*dc*dsc*dp*ic*isc*ip*
alias:          usb:v07B8p8189d*dc*dsc*dp*ic*isc*ip*
alias:          usb:v7392p7811d*dc*dsc*dp*ic*isc*ip*
alias:          usb:v0DF6p0052d*dc*dsc*dp*ic*isc*ip*
alias:          usb:v2019pED17d*dc*dsc*dp*ic*isc*ip*
alias:          usb:v0BDAp817Cd*dc*dsc*dp*ic*isc*ip*
alias:          usb:v0BDAp8178d*dc*dsc*dp*ic*isc*ip*
alias:          usb:v0BDAp8177d*dc*dsc*dp*ic*isc*ip*
alias:          usb:v0BDAp018Ad*dc*dsc*dp*ic*isc*ip*
alias:          usb:v0BDAp818Ad*dc*dsc*dp*ic*isc*ip*
alias:          usb:v0BDAp817Fd*dc*dsc*dp*ic*isc*ip*
alias:          usb:v0BDAp8754d*dc*dsc*dp*ic*isc*ip*
alias:          usb:v0BDAp817Dd*dc*dsc*dp*ic*isc*ip*
alias:          usb:v0BDAp817Bd*dc*dsc*dp*ic*isc*ip*
alias:          usb:v0BDAp817Ad*dc*dsc*dp*ic*isc*ip*
alias:          usb:v0BDAp817Ed*dc*dsc*dp*ic*isc*ip*
alias:          usb:v0BDAp8170d*dc*dsc*dp*ic*isc*ip*
alias:          usb:v0BDAp8176d*dc*dsc*dp*ic*isc*ip*
alias:          usb:v0BDAp8191d*dc*dsc*dp*ic*isc*ip*
depends:        
vermagic:       3.2.0-35-generic SMP mod_unload modversions 
parm:           rtw_ips_mode:The default IPS mode (int)
parm:           ifname:charp
parm:           rtw_initmac:charp
parm:           rtw_channel_plan:int
parm:           rtw_chip_version:int
parm:           rtw_rfintfs:int
parm:           rtw_lbkmode:int
parm:           rtw_network_mode:int
parm:           rtw_channel:int
parm:           rtw_mp_mode:int
parm:           rtw_wmm_enable:int
parm:           rtw_vrtl_carrier_sense:int
parm:           rtw_vcs_type:int
parm:           rtw_busy_thresh:int
parm:           rtw_ht_enable:int
parm:           rtw_cbw40_enable:int
parm:           rtw_ampdu_enable:int
parm:           rtw_rx_stbc:int
parm:           rtw_ampdu_amsdu:int
parm:           rtw_lowrate_two_xmit:int
parm:           rtw_rf_config:int
parm:           rtw_power_mgnt:int
parm:           rtw_low_power:int
parm:           rtw_wifi_spec:int
parm:           rtw_antdiv_cfg:int
parm:           rtw_enusbss:int
parm:           rtw_hwpdn_mode:int
parm:           rtw_hwpwrp_detect:int
parm:           rtw_max_roaming_times:The max roaming times to try (uint)
parm:           rtw_force_iol:Force to enable IOL (bool)
parm:           rtw_intel_class_mode:The intel class mode [0: off, 1: on] (uint)
parm:           rtw_mc2u_disable:int

even after reboot.

edit

I later realized that I blacklisted rtl8192c_common instead of rtl8192c-common. when doing a modinfo rtl8192cu one can see the dependencies:

~$ modinfo rtl8192cu | grep dep
depends:        rtlwifi,mac80211,rtl8192c-common

These in turn:

~$ modinfo rtlwifi | grep dep
depends:        mac80211,cfg80211
~$ modinfo mac80211 | grep dep
depends:        cfg80211
~$ modinfo rtl8192c-common | grep dep
depends:        mac80211
~$ modinfo mac80211 | grep dep
depends:        cfg80211
~$ modinfo cfg80211 | grep dep
depends:        

So in the mean time I have modified my blacklist.conf to look like:

~$ tail -5 /etc/modprobe.d/blacklist.conf 
blacklist rtl8192cu
blacklist rtl8192c-common
blacklist rtlwifi
blacklist mac80211
blacklist cfg80211

but it makes no difference

/edit

share|improve this question
    
you are telling it to load 8192cu on boot do you not want that? –  strings Jan 9 '13 at 3:49
    
What are in install commands in the blacklist.conf? Why are they there? All you have to do is blacklist rtl8192cu, nothing else. On the second though, what makes you think that it didn't work? –  mikewhatever Jan 9 '13 at 5:19
    
strings - yes, that is exactly what I am trying to achieve - for the 8192cu driver to be loaded at boot time. But, as can be seen from the output of sudo lshw -C network, the rtl8192cu driver is loaded instead –  Vuade Jan 9 '13 at 14:11
    
mikewhatever, I read somewhere that if the blacklist commands are used in blacklist.conf, the kernel might still load those modules under certain conditions. The install <module> /bin/false command tells the kernel to never install the module apparently. But as you can see, I've tried both - it makes no difference. –  Vuade Jan 9 '13 at 14:15
    
And to answer your last question, the thing that makes me think it didn't work, is the fact that a, the output of lshw -C network and dmesg tells me that the rtl8192cu driver is used instead of 8192cu, and b, after insertion of another USB device, I experience the same issues as many who had to install the proprietry driver to get the device to function properly. (see e.g. here) –  Vuade Jan 9 '13 at 14:16

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.