Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm using xmonad, and I would like to open a nautilus window to a certain directory, because I like the convenience of browsing inside an encrypted zip file without unzipping it, which nautilus allows.

however, opening nautilus, even with a path argument starts a desktop on the monitor I'm using (There are 8 xmonad monitors) The desktop is inoperative and renders that monitor useless until nautilus is killed.

Is there any way to open just a nautilus window without any desktop starting?

share|improve this question

2 Answers 2

up vote 10 down vote accepted

Execute nautilus with:

nautilus --no-desktop &

You can change the launcher accordingly or create a new one for your purpose.

Edit: Added ampersand so that the process is run in the background. (Props to @user117123)

share|improve this answer
4  
You can also just change the show-desktop setting in dconf to false and it will never do it, instead of changing the launcher. –  dobey Jan 9 '13 at 1:34
    
@dobey With the caveat that a dconf change will apply to all desktop environments you're using. So if you're planning on using both Unity and xmonad you should be careful with this setting. –  Glutanimate Jan 9 '13 at 2:12
1  
And of course nautilus --no-desktop & runs the process in the background and lets you reclaim the command line in that terminal. –  chaskes Jan 9 '13 at 3:34
    
It's not a "caveat." It's a setting. You can change it very easily without having to edit system files, or copy them into special locations and then have to deal with any upstream changes in the future, to those files. And it's unlikely one would really want to have it not work the same way in all environments, or to change environments often. –  dobey Jan 9 '13 at 3:43
    
I plan on using xmonad exclusively. Thank you, this is just what I needed. –  user1552512 Jan 10 '13 at 23:42

Run gsettings set org.gnome.desktop.background show-desktop-icons false and Nautilus will always start without drawing the icons on the background.

You can also run dconf-editor to change the setting with a GUI, if you'd like.

You may need to reset your background image settings, depending on how well the system handles the nautilus background window disappearing.

share|improve this answer
    
dconf did not work for me for some reason, gsettings command did it! –  Gipsy King Jun 21 '13 at 12:21
    
doesn't work for nemo in ubuntu –  ZiTAL 21 hours ago
    
Well, nemo isn't Nautilus, or part of GNOME. –  dobey 19 hours ago

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.